AppCenter does not update

after successful upgrade to 3.7.8 the AppCenter does not update 7 apps:


Here is the output of eos-diagnostic: eos-diagnostic-200330_080427_UTC 0200.txt (1.2 MB)
and the output of flatpak update > flatpak-update_200330_08008.txt 2>&1: flatpak-update_200330_08008.txt (101 Bytes)

Any ideas, how to resolve?

When the problem first occurred, there was Gnome Platform 3.32 labeled as beyond EOS and I uninstalled it (after uninstalling several dependencies related to hack), but sorrily that did not resolve the problem.

  1. Open the application called ‘Terminal
  2. Copy and paste this command into the Terminal application:
killall gnome-software
flatpak update --appstream && flatpak update -y
flatpak uninstall -y --unused
gnome-software

Hi Leandro, thanks, I guess that there is a superfluous newline before the last gnome software, but I realized that too late, i.e. after submitting it, so I guess it removed more than the command you suggested:

 $ killall gnome-software
 $ flatpak update --appstream && flatpak update -y
Updating appstream data for remote eos-apps
Updating appstream data for remote eos-runtimes
Updating appstream data for remote eos-sdk
Updating appstream data for remote flathub
Updating appstream data for remote winepak
Looking for updates…
F: ops remaining after sort, maybe there is a dependency loop?
Nothing to do.
 $ flatpak uninstall -y --unused


        ID                                                      Arch              Branch
 1. [-] org.freedesktop.Platform.Compat.i386                    x86_64            18.08
 2. [-] org.freedesktop.Platform.Compat32                       x86_64            1.6
 3. [-] org.freedesktop.Platform.Locale                         x86_64            1.6
 4. [-] org.freedesktop.Platform.openh264                       x86_64            19.08
 5. [-] org.gnome.Platform                                      x86_64            3.26
 6. [-] org.gnome.Platform.Locale                               x86_64            3.26
 7. [-] org.gnome.Sdk                                           x86_64            3.26
 8. [-] org.gnome.Sdk.Locale                                    x86_64            3.26
 9. [-] org.kde.KStyle.Adwaita                                  x86_64            5.10
10. [-] org.kde.KStyle.Adwaita                                  x86_64            5.11
11. [-] org.kde.KStyle.Adwaita                                  x86_64            5.9
12. [-] org.kde.Platform                                        x86_64            5.11
13. [-] org.kde.Platform.Locale                                 x86_64            5.11
14. [-] org.kde.PlatformTheme.QGnomePlatform.Sources            x86_64            5.11
15. [-] org.kde.PlatformTheme.QGnomePlatform.Sources            x86_64            5.9
16. [-] org.kde.PlatformTheme.QGnomePlatform                    x86_64            5.11
17. [-] org.kde.PlatformTheme.QGnomePlatform                    x86_64            5.9
18. [-] org.kde.Platform                                        x86_64            5.9
19. [-] org.kde.Platform.Locale                                 x86_64            5.9
20. [-] org.kde.Sdk                                             x86_64            5.11
21. [-] org.kde.Sdk.Locale                                      x86_64            5.11
22. [-] org.wesnoth.Wesnoth.Locale                              x86_64            stable
23. [-] org.winepak.Platform                                    i386              3.0
24. [-] org.winepak.Platform.Locale                             i386              3.0

Uninstall complete.
~$ 

and it did not change AppCenter’s behaviour. It still looks exactly as above (besides that on the first restart of AppCenter it reloaded information and listed once FreeDesktop.org Application Platform version 1.6 in the updates and updated it successfully).

Hi!

if you have not been able to update these apps, can you try sudo flatpak update -y, please?

Hi Byron,

thanks, but this results in:

sudo flatpak update -y
[sudo] password for bernhard: 
Looking for updates…
F: ops remaining after sort, maybe there is a dependency loop?


        ID                           Branch           Remote            Download
 1. [✓] org.jamovi.jamovi            stable           flathub           16.6 MB / 360.2 MB

Updating… ████████████████████ 100%  1.7 MB/s  00:00
Note that '/sysroot/flatpak/exports/share' is not in the search path
set by the XDG_DATA_HOME and XDG_DATA_DIRS
environment variables, so applications may not
be able to find it until you set them. The
directories currently searched are:

        ID                           Branch           Remote            Download
 1. [✓] org.jamovi.jamovi            stable           flathub           16.6 MB / 360.2 MB

Updates complete.

but nothing changes in the AppCenter.

The F: ops remaining after sort, maybe there is a dependency loop? is there since quite some time, see my other post some weeks ago.

I’ll just try a reboot …
No change after reboot, I uninstalled “Coding Fun”, and clicked on the update button for “World Literature” now it looks like this:

when I started AppCenter today, there were 13 updates in the queue (including the six from 4 days ago) and AppCenter immediately started installing some of them. The update tab showed first 13 Updates, then went down to 6 updates, but now it returned to 13 updates, despite showing only the same 6 as 4 days ago in the main window.
I append a current eos-diagnostic-200403_093520_UTC 0200.txt (912.6 KB)

still no real change.

Yesterday it looked a bit different: on the updates tab there were no updates left, but the six apps, which were previously listed on the updates tab were listed as “installing” on the Installed tab:

But, when I started today, there was a short notice popping up that six apps were updating and now the six apps are again listed as “installing” on the Updates tab.


Clicking on the “Update All” button changes the appearance of the button for 15 seconds to Cancel but does not have any noticeable results.

Quite strange.

I realized today that Photo Editor vanished from the List and there are only 5 missing updates left:


eos-diagnostic-200417_111719_UTC 0200.txt (1.0 MB)

and once again: this time AppCenter listed 18 apps & runtimes to be upgraded and upgraded 13, but the same 5 remained in the state “installing” as before.

no change of AppCenters behavior after upgrade to 3.8,
but the F: ops remaining after sort, maybe there is a dependency loop? has disappeared.

And today (after upgrade of the eos-runtime), there is an additional error message, but I still don’t know, how to resolve that:

Apparently the problem has disappeared with the upgrade to EOS 3.8.1