ASUS Wifi Issues


#1

Hello, a new Endless OS user here,
I’m using the most recent stable build of Endless on an ASUS X540MA-DM198S laptop (Pentium N5000, 4GB RAM, 240GB SSD) and from time to time (in ~1 hr. intervals) the Wifi connection gets lost, the notification icon shows that the laptop can’t connect to the hotspot (with a question mark) and no other hotspots are visible (although the list is quite full when everything’s ok). After toggling the wifi on and off it fixes itself for the next ~1 hr.
Is there a way to reliably fix this behaviour?


#2

hing that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#3

eos-diagnostic-181124_145548_UTC 0200.txt (576.6 KB)
Here it is :slight_smile:


#4

For further reference: As per THIS I changed the aspm parameter of the r8822be driver to 0 and haven’t experienced any drops since. The penalty, as far as I’ve read, is a bit increased battery consumption but it really seems minor.

To do this, execute the following in the terminal:
echo "options r8822be aspm=0" | sudo tee /etc/modprobe.d/r8822be.conf
When asked for sudo pass, type in your account password.


#5

@jprvita Could help?


#6

Something new (hopefully not related to the above): in the App Center I see lots of update notifications including one for the Endless Platform. After running the updates, a thick grey line remains where the app listing was - like a placeholder for a progress bar. When I click “Update All” again, in a 4-5 sec. a restart prompt appears. After the restart I encounter the same list of apps and platform waiting for an update.


#7

Endless is already aware of this bug are phantom updates the fix is not priority at the moment.


#8

I’ve cleaned the update list with:
sudo eos-fix-ostree-repo

Now let’s see if this cures the updater completely. I hope that the .conf for the network adapter does not break the OS in the same way as sometimes rooting disables OTA in Android… :confused:


#9

@pSy_ZeRo It seems you have already found a workaround for your problem, that’s great. Thanks for letting us know about the problem and the workaround you found. We actually dealt with a similar issue a couple of months ago on a different platform, and at the time it seemed we had fixed it, but apparently we had just reduced the extent of affected machines. We will try to work further with it to find a complete and definitive fix. We may follow up here if we need more information when working on this.

To address your concerns regarding updates, configuring modules to be loaded with certain parameters by default, as you did by creating a file in /etc/modprobe.d, does not influence updates in any way (unless of course your changes affect you ability to connect to the internet). You should keep your workaround in /etc/modprobe.d/r8822be.conf for now and system will continue to receive updates normally. Once the next Endless version is out and you are successfully update and reboot, I encourage you to try to remove that file (you can simply move it to a different place) and reboot once more to check whether the problem got fixed, and if not, you can simply put it back in place and reboot again to re-enable the workaround.


#10

Ok, will keep you posted, @jprvita A bit of a silly question - how to escalate the file manager to SU access so that I can remove the .conf from the folder?


#11

Just shoot in blind.

According to the eos-diagnostics, it is bios_version: X540MA.204 in used.
The new BIOS can be found at https://www.asus.com/us/supportonly/X540MA/HelpDesk_BIOS/. The latest version is 301 now and worth trying.


#12

@starnight did that, thanks, will see what happens next…


#13

@pSy_ZeRo I don’t recommend running the file manager with super-user privileges. I know I mentioned moving the file to a different place in my previous comment, but on a second thought it is actually easier and better if you remove it and reboot to remove the workaround, with the command bellow on the terminal (just be cautious with typos so you don’t end up removing something else):

sudo rm /etc/modprobe.d/r8822be.conf

and reboot the machine.

Then if you need to get the workaround back in place, simply issue the same command on the terminal that you have issued before:

echo "options r8822be aspm=0" | sudo tee /etc/modprobe.d/r8822be.conf

and reboot again.


#14

You don’t want to run the file manager itself under SU; but you can press Ctrl-L and enter admin:///etc/modprobe.d to get an escalated view of that folder.


#15

@jprvita, @wjt, thank you! The BIOS is now current and I removed the Realtek .conf for now… will test how the wireless behaves in the next few days… Seems stable so far.


#16

Well… the bug is back - and so is the workaround. I guess that ASPM can be problematic on some laptops.


#17

@wjt, @jprvita unfortunately I am experiencing glitches even with the aspm hotfix after the most recent Endless OS update - with lots of tabs open in Chrome, suddenly the connection drops out with a question mark on the wifi icon. Closing Chrome and toggling the wireless adapter off/on helps for some time but I think that it shouldn’t be like that :frowning:
EDIT: To be more precise, this is with ~10-12 tabs open and only ~0,6GB RAM left free (out of 4GB).


#18

The next time this happens, please get a new eos-diagnostics file, and send it to us, along with the output from the following two commands:

nmcli
nmcli g

(The ? logo on the wireless network can mean that the network link is up, but the connectivity check – “is this network actually connected to the internet?” – has failed.)


#19

@wjt, I managed to reproduce it with a dozen tabs so here it is:
nmcli:

wlo1: connected to WiFiNetHome
“Realtek RTL8822BE 802.11a/b/g/n/ac WiFi”
wifi (r8822be), 80:C5:F2:B6:22:D1, hw, mtu 1500
ip4 default
inet4 192.168.0.103/24
route4 0.0.0.0/0
route4 192.168.0.0/24
inet6 fe80::41dc:be7f:46ae:fc9/64
route6 ff00::/8
route6 fe80::/64
route6 fe80::/64

lo: unmanaged
“lo”
loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
servers: 192.168.0.1
interface: wlo1

nmcli g:

STATE CONNECTIVITY WIFI-HW WIFI WWAN-HW WWAN
connected full enabled enabled enabled enabled

The diagnostics is here:
eos-diagnostic-190103_213657_UTC 0200.txt (1.0 MB)


#20

The problem is still here and makes the computer borderline unusable for any sort of multitasking that involves serious RAM load :frowning:
edit: Reapplied the r8822be workaround, let’s see if that makes a difference.