ASUS Wifi Issues


#9

@pSy_ZeRo It seems you have already found a workaround for your problem, that’s great. Thanks for letting us know about the problem and the workaround you found. We actually dealt with a similar issue a couple of months ago on a different platform, and at the time it seemed we had fixed it, but apparently we had just reduced the extent of affected machines. We will try to work further with it to find a complete and definitive fix. We may follow up here if we need more information when working on this.

To address your concerns regarding updates, configuring modules to be loaded with certain parameters by default, as you did by creating a file in /etc/modprobe.d, does not influence updates in any way (unless of course your changes affect you ability to connect to the internet). You should keep your workaround in /etc/modprobe.d/r8822be.conf for now and system will continue to receive updates normally. Once the next Endless version is out and you are successfully update and reboot, I encourage you to try to remove that file (you can simply move it to a different place) and reboot once more to check whether the problem got fixed, and if not, you can simply put it back in place and reboot again to re-enable the workaround.


#10

Ok, will keep you posted, @jprvita A bit of a silly question - how to escalate the file manager to SU access so that I can remove the .conf from the folder?


#11

Just shoot in blind.

According to the eos-diagnostics, it is bios_version: X540MA.204 in used.
The new BIOS can be found at https://www.asus.com/us/supportonly/X540MA/HelpDesk_BIOS/. The latest version is 301 now and worth trying.


#12

@starnight did that, thanks, will see what happens next…


#13

@pSy_ZeRo I don’t recommend running the file manager with super-user privileges. I know I mentioned moving the file to a different place in my previous comment, but on a second thought it is actually easier and better if you remove it and reboot to remove the workaround, with the command bellow on the terminal (just be cautious with typos so you don’t end up removing something else):

sudo rm /etc/modprobe.d/r8822be.conf

and reboot the machine.

Then if you need to get the workaround back in place, simply issue the same command on the terminal that you have issued before:

echo "options r8822be aspm=0" | sudo tee /etc/modprobe.d/r8822be.conf

and reboot again.


#14

You don’t want to run the file manager itself under SU; but you can press Ctrl-L and enter admin:///etc/modprobe.d to get an escalated view of that folder.


#15

@jprvita, @wjt, thank you! The BIOS is now current and I removed the Realtek .conf for now… will test how the wireless behaves in the next few days… Seems stable so far.


#16

Well… the bug is back - and so is the workaround. I guess that ASPM can be problematic on some laptops.


#17

@wjt, @jprvita unfortunately I am experiencing glitches even with the aspm hotfix after the most recent Endless OS update - with lots of tabs open in Chrome, suddenly the connection drops out with a question mark on the wifi icon. Closing Chrome and toggling the wireless adapter off/on helps for some time but I think that it shouldn’t be like that :frowning:
EDIT: To be more precise, this is with ~10-12 tabs open and only ~0,6GB RAM left free (out of 4GB).


#18

The next time this happens, please get a new eos-diagnostics file, and send it to us, along with the output from the following two commands:

nmcli
nmcli g

(The ? logo on the wireless network can mean that the network link is up, but the connectivity check – “is this network actually connected to the internet?” – has failed.)


#19

@wjt, I managed to reproduce it with a dozen tabs so here it is:
nmcli:

wlo1: connected to WiFiNetHome
“Realtek RTL8822BE 802.11a/b/g/n/ac WiFi”
wifi (r8822be), 80:C5:F2:B6:22:D1, hw, mtu 1500
ip4 default
inet4 192.168.0.103/24
route4 0.0.0.0/0
route4 192.168.0.0/24
inet6 fe80::41dc:be7f:46ae:fc9/64
route6 ff00::/8
route6 fe80::/64
route6 fe80::/64

lo: unmanaged
“lo”
loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
servers: 192.168.0.1
interface: wlo1

nmcli g:

STATE CONNECTIVITY WIFI-HW WIFI WWAN-HW WWAN
connected full enabled enabled enabled enabled

The diagnostics is here:
eos-diagnostic-190103_213657_UTC 0200.txt (1.0 MB)


#20

The problem is still here and makes the computer borderline unusable for any sort of multitasking that involves serious RAM load :frowning:
edit: Reapplied the r8822be workaround, let’s see if that makes a difference.


#21

There can be setting on wifi modem, that set the time how long your connection can last. This is more common on some public wifi modem. Looks like you do not have this, you can look it up. To be sure, by connecting your self locally to modem menu and see it there.


#22

Unfortunately, 2 other laptops and 2 smartphones have no such problems with the same router…


#23

Still no luck with this one. Under more serious load (~80% RAM load with it being mostly Chrome tabs) the adapter hangs and needs to be disabled via airplane mode and re-enabled to work again.


#24

So much time later - still no fix. From what I read, this is not really an Endless-only bug but more of a Kernel thing instead - users with Mint and Ubuntu are facing similar issues as well. I still hope for an update because r8822be is kind of widely used wifi adapter - with Asus, Acer and Lenovo (and maybe more) using it in their laptops…


closed #25

opened #26

#27

Yeah, sorry that we sort of let this drop. As you spotted it’s not exactly a bug that belongs to us.

Good news though, in the time that has passed, Realtek has published a new driver for this hardware (“rtw88”) and it’s much better from a tech perspective.

That new driver actually a more serious version of the same bug that you are triggering wth Chrome (instead of losing wifi it actually crashes your kernel) but my colleague Jian-Hong is collaborating with the driver developers and it looks like we almost have a fix in place.

If it goes well we’ll look at getting this into Endless (or at least available on the beta channel) during the next few weeks.


#28

Thanks for the update! I surely hope that we will end up having a driver that is both stable and better working than the current :slight_smile: For now an extension such as The Great Suspender more or less makes do but not if you are working with heavier web apps (e.g. BandLab)… Then you are in trouble even with a single tab open.