Bluetooth missing after upgrade

Hi! Just upgraded to 3.8.0 and bluetooth isn’t recognized anymore (it was never working quite right, poor range, choppy sound, etc…)

eos-diagnostic-200508_041524_UTC-0300.txt (429.7 KB)

Can you please post the output of:

bluetoothctl show

This should display something like:

Controller 00:1B:DC:06:A7:A1 (public)
	Name: omikron
	Alias: omikron
	Class: 0x00000104
	Powered: yes
	Discoverable: no
	Pairable: yes
	UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
	UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
	UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	Modalias: usb:v1D6Bp0246d0532
	Discovering: no

If something like this is display, please try to pair something on the commandline with:

  1. Run bluetoothctl
  2. Now type agent on (confirm with Enter)
  3. Put the device to pair in pairing mode (i use a mouse in my example)
  4. Now type scan on (confirm with Enter)
  5. Something like the following should be displayed:
[CHG] Controller 00:1B:DC:06:A7:A1 Discovering: yes
[NEW] Device 59:37:24:9B:A2:98 59-37-24-9B-A2-98
[NEW] Device ED:8E:0E:D7:1C:E2 RAPOO BleMouse
[NEW] Device ED:8E:0E:79:1B:E2 RAPOO BleMouse
  1. Type pair ED:8E:0E:D7:1C:E2 (replace the Hexadecimal string with the identifier of your device)
  2. Type trust ED:8E:0E:D7:1C:E2
  3. Type connect ED:8E:0E:D7:1C:E2. Now something like
[CHG] Device ED:8E:0E:D7:1C:E2 Connected: yes

should be displayed and the device should work.
9. Exit with exit



Let us know if it worked.

1 Like

hi Egon! That command shows: No default controller available

OK, after doing a little bit of Google Research, i think you run into the following bug, which affects Kernel 5.4:
Until this gets fixed, i recommend you to stay at your previous Endless OS installation. Run:


thanks! Could i just downgrade the kernel but not the whole os version?

No, EOS is OSTree based and performs updates on a atomic basis. So you can only revert to the last version at a whole (which is a good thing for not breaking things)

oh ok… well thank you very much for your help! Let’s hope the fixed kernel and the updated system come soon

Excuse me, can I ask you something out of the question?
What happens when you execute a command
Is the current OS version removed or is the GRUB menu being edited?

Essentially, eos-rollback switches your OSTree Deployment to the previous one. The EOS Updater keeps two copies when doing upgrades - the one you had until now and the new one. The GRUB Bootloader is configured to allow you to boot to either of them and uses the active one by default.

To view your OSTree Deployments, run:

ostree admin status

The one marked with an Asterix is the active one. So at least in theory, you should never end up with a broken system, as:

  1. The system including all of the dependencies is updated at a whole
  2. If something goes wrong, the entire update transaction is rolled back
  3. You can always switch to the previous deployment which worked

Sorry for the inconvenience here. This should be working again as well as it did previously in Endless 3.8.1.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.