Bring dosbox-x to endless


#1

Hi!

Dosbox-x has a flatpak edition (https://github.com/egrath/dosbox-x-flatpak/releases) but I can’t install it on my Endless. Please work around it.
p.s.: DosBox and DosBox-x are two separate apps.

Thank you very much!


#2

Hi,

What issue do you have with the Flatpak? Just updated it a few days ago to 0.82.20, switched to SDL2 and built it on 3.6.2.

I uploaded you a binary build of the current version here:

DOSBox-X 0.82.20 Flatpak Binary

Just install it with:

flatpak install --user dosbox.flatpak

egrath


#3

Hi,

Thank you for your fast reply.

Unfortunatly, it doesn’t work either. I tried installing via GUI and now via the terminal as you suggested. It gave me the same error:

“… appstream.xml.gz no such file or directory”


#4

Hm… interesting. Will check this after the weekend, as i’m on vacation now for a few days. But i will fix it, as i intend to push it to flathub during the next week.


#5

THanks! Enjoy your vacation! :sunny:


#6

I just installed it on a fresh 3.6.2 installation with the following commands, without any issues:

git clone https://github.com/egrath/dosbox-x-flatpak.git
cd dosbox-x-flatpak
git submodule init
git submodule update
flatpak-builder --user --force-clean --install-deps-from=flathub build com.github.joncampbell123.DOSBox-X.json
flatpak-builder --repo=repo --force-clean build com.github.joncampbell123.DOSBox-X.json
flatpak build-bundle repo dosbox-x.flatpak com.github.joncampbell123.DOSBox-X 0.82.20
flatpak install --user --assumeyes dosbox-x.flatpak

Can you please try them out and report any problems.


#7

Hi!

Hope, you’ve enjoyed your vacation!
Well, this time (probably thanks to the cd command that was not in the github description) the git commands ran well. “flatpak-uldier --user…” gave an error:

error: No remote refs found similar to ‘flathub’
Error installing deps: running flatpak --user install flathub -y --noninteractive org.freedesktop.Sdk/x86_64/18.08: The child procedure exited with the following code: 1

Well, this happened… :frowning:


#8

It seems to me, that for some odd reason, you don’t have the flathub remote configured …
Can you please run:

eos-diagnostics

and upload the resulting file to this thread.


#9

I think this is happening because you have the remote configured in the system repo, but not in the --user repo.


#10

@egrath:
Here you go:

eos-diagnostic-190821_023131_UTC 0200.txt (1.3 MB)

:slight_smile:

@wjt: Thank you for commenting! :slight_smile:
It sounds reasonable as much as I understood it. But I have no ideal what to do. Maybe I should run:

flatpak-builder --system --force-clean --install-deps-from=flathub build com.github.joncampbell123.DOSBox-X.json

or should I go to a different directory after opening the Terminal. e.g.

cd /sysroot/home/.var/app/

and then run the codes that @egrath suggested above?

Thank you for both of you in advance. Have a nice day!
:slight_smile:


#11

Simply remove the

--user

flag from the commands above, it will install everything systemwide. You will get asked a few times to authenticate yourself.