Can I just buy Endless OS on a USB stick?

I’ve had nothing but trouble trying to create an Endless OS USB drive. Using two different computers with two different USB drives, it ends up the same. Somewhere along in step 3, an extra partition is created and that where the download want to go but its 1MB in size. It’s either that or the computer reports that the file system is unknown. I’ve tried using Diskpart in Windows to delete the extra partition and now neither USB drive shows up in Windows Explorer. Has anybody else had this problem and overcome it? If so, would you be willing to share the solution? The best solution would be to just buy an Endless OS stick. Can I do that? I really want to try it out. Thanks.

Hmmm. Interesting, Leandro. Do you know if the “Hack Key” version of Endless OS differs from the free version? I would want my copy to be like the full version and not a customized version for kids. Also, does the Hack Key version give you the option to install the OS permanently? Thanks.

Hi,

Are you following these instructions? https://support.endlessm.com/hc/en-us/articles/115002984283-How-do-I-create-an-Endless-OS-USB-stick-on-Windows-

Yes. I followed these instructions to the letter on two different laptops with two USB drives. It gave the same outcome I wrote about earlier.

Maybe it would be helpful if you posted screenshots of what you’re seeing. Especially on the “Select USB Drive” screen of the Installer.

You should run the Installer from your Downloads folder. The exe file does not need to go on the USB drive, just in case that’s what you were trying to do.

I do run the installer from the downloads folder. The problem shows up during step 3 - writing the file to the USB stick. If I could make the 15GB file go into the Windows Downloads folder, I’d be set.

The download should happen in the same folder (or within a new subfolder) as the installer .exe. If you are already on step 3 where it is writing to USB, then that implies that the download was already complete.

We are aware of problems seen on some computers in creating the USB disk, and you may be hitting that. A log file should be generated in the same directory as the installer, if you post it here we may be able to confirm this is what you are facing.

We have a new version of the windows installer in development that should improve this. However in the mean time, there is an alternative way for you to create an Endless USB which you can try instead: You can download an Endless OS ISO image and write it to the USB disk with Rufus .

Daniel,

Why is this process being made so damn difficult and exasperating? Every Linux ISO I’ve tried is hosted, immediately available for download, and can be loaded onto a USB drive with Rufus. I’m being offered 300 KB torrent files. What am I going to do with that? I don’t use torrents. I don’t want to learn how to use torrents. I simply want a file I can download and load with Rufus. Can you hook me up with the Full 15GB Version ISO independent of the Windows-based installer and USB Stick Creator…please?!!

Jerry

I’m sorry for the difficulty here. We will look to make torrent instructions (& details about the alternatives) clearer on the website going forward.

Please click the link I provided above:

On that page you will see a tabular list of downloads titled “Endless OS 3.7.8”
Select the version that you want to download, and then click the “.iso” link in the Direct Download column. This is not a torrent download.

If English Full is the download you are after, you can try this direct link: https://images-dl.endlessm.com/release/3.7.8/eos-amd64-amd64/en/eos-eos3.7-amd64-amd64.200310-014325.en.iso

Daniel,

I know you’re trying to be helpful. The link you provided is where everything came to a screeching halt. Can you just provided a link to download the ISO without using torrents? It would simplify the process. We can use Rufus at that point and we’ll be running Endless OS in no time.

Jerry

Thanks for your interest!

There are non-torrent iso links on that page, here it is for full English: https://images-dl.endlessm.com/release/3.7.8/eos-amd64-amd64/en/eos-eos3.7-amd64-amd64.200310-014325.en.iso
15GB download, direct link, no torrent.

Daniel,

I downloaded the file from the link you sent me. It claimed to be a Disc Image file. Copied it to m USB drive as-is. Was not recognized in either NTFS or FAT32. After restarting my laptop, I clicked on the download. It created this: DVD Drive (E:) Endless OS 3.7.8 en When I click on this description I see four items in Windows Explorer: the Endless file folder, an Autorun file, a boot catalog file, and the endless installer. Nothing in the Endless OS file folder resembles an ISO. The largest file in there is a squash file which is about the same size as the download. Could you give me step-by-step instruction on what to do with all this? Thanks.

Jerry

The Disc Image file you downloaded is an ISO file so you now need to use Rufus to flash that file to the USB disk.

Ignore the first section there, scroll down directly to " Here’s an example of how to make a USB stick using the Rufus program" and follow those steps. In step 2, select the iso file you have downloaded from above.

After that, you will need to plug the USB disk into the target computer, and then use the BIOS menu or boot menu to make the computer boot from the USB disk. Let us know if anything is unclear!

Daniel,

EOS was worth the wait. (I’m typing from within a live session.) From the beginning, I misunderstood the installation instructions. (Sorry about that. I apologize for being short-tempered.) Using the Windows installer, I made the mistake of thinking that when I saw a couple of Windows Explorer panes open about 10% of the way in step 3, I mistook those Explorer panes as failure to execute the USB stick creation. Ignoring the panes, I just let the process continue until EOS said the USB stick was ready for use. May I suggest that you insert an explanation that these Windows Explorer panes are to be expected and then ignored? Just the inclusion of that phrase would’ve resulted in a successful USB drive creation the first time out. (Sometimes, we noobs need more explanation of the process.) Be that as it may, the whole USB stick creation process took nearly 30 minutes after downloading.

Thanks for your help,

Jerry

We have a feeling this awkward Windows Explorer behaviour does not happen on all computers, may depend on specific settings or versions of Windows or something. We should find a place to document it regardless. Thanks for sticking with it and taking the time to provide constructive feedback!

Daniel,

I’ve decided to install Endless OS side-by-side with Windows but I’m a little confused by the instructions. Does it actually install on the C:\ drive or am I reading it wrong? (My intent is to split the 240 GB SSD equally.) I’m referencing the EOS page: https://support.endlessm.com/hc/en-us/articles/212890106-How-do-I-install-Endless-OS-alongside-Windows-

Thanks in advance fro your help.

Jerry

Yes. C:\ drive :endless: