Can't install VLC and Spotify


#53

eos-diagnostic-180327_171215_UTC 0800.txt (344.7 KB)


closed #54

opened #55

#56

@liezeljustine12 I’ve merged your other topic about Spotify with this one, because I think it’s a configuration problem affecting your machine that causes both issues.

Do you know why you might have an /etc/flatpak/remotes.d/flathub.conf file? It’s not something that Endless OS would create for you automatically. Do you remember following some steps to install/create it?

I think we can fix your system though. Close the App Center, then run each of these commands:

killall gnome-software
sudo rm /etc/flatpak/remotes.d/flathub.conf
flatpak uninstall io.webtorrent.WebTorrent
flatpak remote-delete flathub-1
sudo eos-update-flatpak-repos

You should be able to re-open the app center then, and re-install WebTorrent, VLC, Spotify and anything else you need.


#57


#58

@liezeljustine12 Looking pretty good, just one weird thing. Try these two commands again. Note that they are CaSe SeNsItIvE - we got an error last time because you typed Webtorrent instead of WebTorrent. Maybe copy/paste them:

flatpak uninstall io.webtorrent.WebTorrent
flatpak remote-delete flathub-1

#59


#60


#61


#62

Sorry you’re having so many problems. Close the app center and run the killall gnome-software command again. Launch it again though the icon, wait for it to download any updates, then try the searches one more time. If things aren’t working then, attach a new diagnostics log.


#63

yeeyy! im already installing spotify. thank you!


#64

Wooooooow! What a relief. Sorry again this was working so badly for you. Did you have any idea where your flathub.conf file came from?


#65

can i change the spreadsheet writer and presentation??


#66

i followed @leandrostranger


#67

You can upgrade to a newer and better version of LibreOffice using the command line, but for the moment this will cause you to have two sets of LibreOffice icons visible in the desktop / app search.

If you’re OK with this and want to try the new version, run this command:

flatpak install flathub org.libreoffice.LibreOffice

The icons on the desktop with the rectangular “paper” icon named “LibreOffice …” are the new version 6.

This version is hidden from the App Center to avoid people seeing the duplicates in the app center. We’re planning to change Endless OS to this version by default but the work is not quite complete yet.


#68


#69

@ramcq help me please…


#70

Hi @liezeljustine12 ,
I have just tried installing Spotify and it worked for me. Can you try again? (it could have been a temporary problem in the server)

Thank you for your patience,


#71

Oh. Thank you ::smiley:


Can't install Spotify
closed #72