Encyclopedia not working properly


#1

Hello, I am new to Endless OS but very impressed.

It is possible the default Encyclopedia App pm the Desktop does not work in french ? I can type words, click them but nothing show up

I tried in english and same results ( installed Endless OS english in a VM to test)

JF
Good job to the team… I tried 10, 20 Linux distro and Endless is " SO Sharp / Clean, Simple"… Talking to people about it already


#2

OK I realized I use the French iso and saw your website after that english is more fully supported
And my English test was done using the french iso choosing English as default language

Now I will download the English ISO to see if Encyclopedia is working better
JF


#3

ok Same results with a full English installation from the english iso
JF


#4

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#5

eos-diagnostic-180618_174126_UTC-0400.txt.txt (640.3 KB)

Here it is


#6

and if I click a word, the window stay BLANK
JF


#7
Jun 18 16:25:12 endless gjs[1715]: JS WARNING: [/usr/share/gjs-1.0/overrides/endless_private/search_box.js 157]: reference to undefined property Symbol.toPrimitive
Jun 18 16:25:14 endless gjs[1715]: JS ERROR: Gio.IOErrorEnum: Operation not supported
                                   EknWebview<._load_ekn_uri@resource:///com/endlessm/knowledge/js/app/widgets/eknWebview.js:157:30
                                   wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                   @<command line>:10:1
Jun 18 16:25:38 endless WebKitWebProces[1745]: The program 'WebKitWebProcess' received an X Window System error.
                                               This probably reflects a bug in the program.
                                               The error was 'BadMatch (invalid parameter attributes)'.
                                                 (Details: serial 211 error_code 8 request_code 72 (core protocol) minor_code 0)
                                                 (Note to programmers: normally, X errors are reported asynchronously;
                                                  that is, you will receive the error a while after causing it.
                                                  To debug your program, run it with the GDK_SYNCHRONIZE environment
                                                  variable to change this behavior. You can then get a meaningful
                                                  backtrace from your debugger if you break on the gdk_x_error() function.)
Jun 18 16:25:38 endless kernel: traps: WebKitWebProces[1745] trap int3 ip:7f6a310bae91 sp:7ffdf7c50bc0 error:0 in libglib-2.0.so.0.5400.3[7f6a3106b000+112000]

@ptomato any ideas? Fallout from a GJS or WebKit upgrade?


#8

Ok, I found it.

if Endless is installed on a computer and not in a VM (Virtual Box), Encylopedia is working well
JF


#9

Huh, that’s very strange. This error usually shows up when misusing threads, but we don’t use threads in the Encyclopedia app.

From your update I’d guess that it’s a bug in WebKit with the VirtualBox video driver. Try turning off 3D acceleration in VirtualBox if it is on. I have definitely had problems with that before.


#10

I will try and let you know
JF


closed #11