HDMI from laptop to TV


#21

@thetechiemon

Hey I did some digging on said hardware and found the following info. The max supported over hdmi output for this chip is limited to 1080p60. I can’t confirm this info at all but it seems a hint in the right direction.

While the info from this page is a bit contradicting. Hdmi 1.4 should add support for 4K. Or said laptop manufacturer has cheaped out on and using hdmi 1.3 which only supports 1080p max. Again I do not know much about atoms and how intel can restrict such things.

Here’s the link and a screencap



#22

@muffin

Very interesting and a good find!

That max resolution proves to be exactly the max resolution of the screen on the laptop itself.

I’m now wondering if the modesetting driver in Endless is ‘trying’ to drive the TV at it’s native resolution and the hardware simply cannot achieve it…

My other laptop is quite a bit older than the Atom based one and the resolution is 1366x768 so quite a bit lower… I use the modesetting driver on this and at this resolution with no issues.

I’m tempted to do some digging in the area of resolution and max refresh rates for the Intel and modesetting drivers!


#23

For modesetting in what I know display on the device is independed from output ports as of they aren’t limiting each other from the max resolution output is in simple terms.

Main display connector from pcb -> modesetting config as device 1
Hdmi connector from pcb -> modesetting config as device 2
List goes on

I’m shooting into the blue by saying the modesetting driver gets reported a hdmi 1.4 port by hardware id expecting it to drive 4k while the firmware information on said cherry trails have a 1080p limitation coded in some wizard ways I’m unaware of -> intel microcode -> cpu firmware -> bios. Could be anything really. As far as this goes it feels like I’m digging way too deep into company secrets then I should be.

For the super doofus idea. Has said notebook a specific function button to switch to external display? Maybe FN + F10 or with hotkey on some models just one of the F - keys? Any change when pressing that. Another shot into probably nothing but worth a mention.


#24

I could dig around with this forever - I love this kind of thing!

What is strange is that the old Intel driver just works if I use it - the new modesetting driver doesn’t - another case of fixing something to break something else, I feel.

TBH, I can use the Intel driver for the odd occasion when the laptop gets used on the TV - the whole thing started when my daughter wanted to show some holiday photos to her friends - I love being the IT guy / tech support for the family!! It works fine on her TV (a generic 1080p panel) with modesetting so she’s happy!

There are no function buttons for switching display on this particular laptop - it doesn’t even have a “backslash” key and it came pre-installed with Windows 10 - I have no idea how I was expected to use the command line to navigate around the file structure :smiley: I love these cost-saving measures…


#25

Hi guys,

I need to tell you that this is the first time I am using a linux based OS and I am aeos-diagnostic-181206_164740_UTC 0200.txt (3.6 MB)
total noob. I need you help. I have the same issue with a 4k LG TV (When I connect the HDMI cable it detects another TV - Goldstar Company and different size 72 inch instead of 55 - the model of my TV is UK6200PLA). Maybe it’s important to mention that my laptop screen doesn’t go blank when I insert the HDMI cable (I can still use the laptop), but the TV doesn’t get any signal.
I tried creating the intel.conf file and I finally managed to do it after a lot of google search because I didn’t have permission to save files in that folder, but after I did this thy system wouldn’t boot anymore. I had to access the GRUB menu and boot an older version than updated it again.
This is the output for when I typed xrandr --listproviders in the Terminal window:

Providers: number : 2
Provider 0: id: 0x215 cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x46 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 4 associated providers: 1 name:modesetting

Please let me know if you need any additional information. Please help! :slight_smile:
Thank you!
I also added the diagnosis file.


#26

Sorry for the delay in getting back to you.

The logs indicate that your TV was successfully detected.

Have you tried going into Settings -> Devices -> Displays and changing the resolution used to output to the TV?

Have you confirmed that your TV has the right HDMI input source selected?


#27

Hi Daniel,

Thank you for your reply, but I already did all that and the TV is simply not getting any signal. As I told you before, the TV is detected, but another brand and another size (Goldstarcompany 70" instead of LG 55").
Do you have any other suggestions?
Thank you!

Best regards,
Bogdan


#28

Don’t worry about the TV information being reported incorrectly.
Can you test the same computer connected to other TVs?
Can you test other computers connected to the same TV, ideally running Endless (e.g. in live mode from USB)?


closed #29