How to turn on discrete videocard?

Hello! after last apdate to 3.7.7 my default videocard changed to integrated. How to change it to discrete? for playing games.

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

eos-diagnostic-200213_003032_UTC 0300.txt (3.1 МБ)

Hello! after last apdate to 3.7.7 my default videocard changed to integrated. How to change it to discrete? for playing games.

Open up a terminal and enter:

sudo bash
echo DRI_PRIME=1 >> /etc/environment
reboot

Verify with:

glxinfo | grep "OpenGL renderer string"

This outputs which card is used for doing 3D acceleration. Note that with the above procedure, your system always uses the dedicated gpu.

Sorry for the difficulties here. You have run into a problem in our latest 3.7.7 release, the nvidia driver can’t be loaded.

We are working on a solution here, in the mean time you have 2 options:

  1. Go into your BIOS setup menu and disable Secure Boot. Nvidia graphics will now work again. It’s a security feature so I would not recommend turning it off long term, but perhaps it’s OK for now.
  2. In the terminal run:
    sudo eos-rollback
    This will revert you to the previous Endless version where nvidia works, then you can update again later once we have fixed the issue

Thanks! But, you understand, it is only temporary solutions. So, i’ ll try to do it and will wait for the full solution.

  1. Can’t to disable secure boot. This field is inactive. And nothing makes to change it.

Can you send a photo of this field to illustrate better what you mean?

On Acer devices, you first need to set a Supervisor-Password in order to disable SecureBoot. Otherwise the option will be grayed out you are not able to change it.