Installation on Raspberry Pi 4 (4GB) with SDCARD gets stuck on rainbow splash

I used BalenaEtcher to flash the “basic” Endless OS image for Raspberry Pi onto a 32GB sdcard. When I put the card in the Raspberry Pi and boot, I get a multicolor (rainbow) screen and nothing else. What ight be going on here?

If your screen looks like:

Then this could means two things:

  • The RPI isn’t able to load the kernel Image, which can occur if something happened during the write or as a result of a failing SD card
  • Your power supply isn’t sufficient enough to provide enough juice. Use at least some PSU which can supply 2.4 Amps.

For the first case, try to rewrite the Image to another SD and/or use another writing Tool. I almost always use “Win32 Disk Imager” to write raw Images to USB-Sticks and SD cards and never had any issues with it.

I tried raspbian on the same sdcard and power adapter. Works perfectly fine. Endless OS remains stuck on the rainbow screen. And yes, it looks exactly like you pointed out.

I tried flashing the sdcard with win32 disk imager, same result. I am using 3.8.5 btw.

I also mounted the sdcard on my Mac to confirm that kernel8.img file is there.

The problem seems specific to endless.

I am using Pi 4B rev 1.2.

So, I was downloading the basic version through torrent. I switched to using direct download and now I am getting this.

Have tried Rufus, win32 disk imager, balena etcher and get the same result.

Raspbian image still works fine when flashed on the exact same sdcard.

This is really frustrating.

Tried Linux as well to flash the endless img.xz using the gnome-disks utility.

Same result.

Here is how the filesystem layout looks like on the SDCARD after flashing the endless img.xz file.

Also tried a different 32GB sdcard. Same result.

Please try again in 3.8.6. Hope it fixed.
I also stuck on boot in 3.8.5 (Raspi 4 8 GB)

Do you get the same error as shown in the picture of boot messages I posted earlier?

I got this when following instructions (workaround) from Can't Boot Endless 3.8.4 on Raspberry Pi 4. Maybe I put something in config.txt wrong,

My problem is different now. I don’t get the rainbow screen anymore after using the direct download instead of torrent.

However, I get the “non fat partition” error as shown by a boot messages picture above.

I have no idea what is going on here.

I manually mounted the EFI partition and that seems to be fine. I don’t know why the boot messages are saying “non fat partition”.

Hey @cho2 and @nixbox , the 3.8.6 image for RPi4 is not ready yet, will be release soon in next couple days.

1 Like

thank you, can’t wait to try it out

It works with 3.8.6!



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.