Media driver not found on bootable usb

First, sorry if any interpretations problems occur because english is not my native language.
Second, in resume, my problem is that my Endless SO is causing me headache to install win10.

Context: Just bought an Acer Nitro notebook that comes with Endless SO. I have a license to use win10 but in order to install it I need to create a bootable media, which I do, but when I boot it, he try to install and get the error “missing driver” like something is not on the media boot I’m using, I guess.

  1. I first fixed a error that BIOS did not recognize my bootable device. This error is long gone.
  2. Before I boot the media, I tried disabling the secure boot, and nothing changed. I tried switching UEFI to Legacy and nothing changed, same error occur. I tried using different usb ports, and nothing changed.
  3. Guessing the error is on my pen drive. I read on thousands of similar errors and one guy managed to solve the problem by using another pen drive. This is crazy, seems stupid, but I didn’t try it yet. What I did was use a different media creator, like Rufus, differently from the official Windows app. Same error.

Someone please help, I’m loosing it.

We can not help you
We only support Endless OS


We are very sorry to hear that EOS did not fulfill your needs, unfortunately, the installation of other OS which is not Endless OS is out of our hands, we kindly suggest contacting your distributor or even microsoft to have a better guidance on how to install their system.

All the best,

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.