Podman 1.5.1 upgrade

Despite my mistake: Is there any chance to get podman upgraded and how?

Unfortunately, there’s no easy way to upgrade this component of EOS separatly from the main system, as it’s heavily tied into the operating system (libpod, …).

So we have to wait for the Endless developers to step in and update it.

Sorry for the delay here. podman is one of those things that is a bit difficult for us to maintain so we have fallen a bit behind as you have spotted.
We have a plan for how to update and how to make it easier to keep up-to-date going forward, but have not found the time to make this happen just yet.
Is there a specific feature or fix that specifically draws your attention to this updated podman version?

yes, absolutely, I urgently need RStudio. In my original post, I crosslinked to a lengthy discussion about a flatpak for RStudio, which is in turn crosslinked to several other places about getting a maintained version of RStudio up and running under EndlessOS. Using a Docker image with podman might be a viable way, but podman 1.5.1 has problems with running /init as root in the container. The problems are apparently resolved in podman 2.1.1 (see Enchufa2’s post in the crosslinked flatpak for RStudio thread). I am eagerly waiting since almost two years for a solution (see also What about R in endless), but there is still no really viable solution despite several efforts …

@Daniel any news about a perspective for upgrade to podman 2.x

Thanks for the info. In terms of a possible quick solution, I wonder if there is a non-intrusive fix that can be identified and easily backported to podman 1.5 to solve your issue. Or if @andrunko can think of any other low-effort solutions to make this work.

Otherwise, to be honest, it’ll probably be a few months before we upgrade, I apologise for any inconvenience. The situation is that we have our distro based on Debian, but the podman packages weren’t in Debian until recently, so we got them from elsewhere, and that makes maintenance a bit painful.

Now podman is officially included in Debian, we should switch to that version instead, but… our whole distro maintenance process is quite manual, and Debian has packaged every single go module as an individual source package, so that equates to a bunch of awkward work.

What we’re working on instead is becoming directly aligned with Debian so that we don’t have our own entire separate distro, at which point adopting Debian’s podman package and dependencies becomes something trivial and automatic. We’re also working on opening up our tools, infrastructure and communication to increase transparency with partners and enable more community involvement. These transitions are taking some time but should bring many rewards going forward.


thanks for the offer, the current workaround as outlined by @egrath is viable, although a little bit tedious (starting a bash in the image and running /init manually), so I will be patient.

@Daniel thanks a lot for the infos about future plans, sounds very promising and yet another reason for being patient. I guess that will be the next major release, i.e. 4, or am I wrong here?

congratulations :+1: :+1:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

Just as a quick update, we are proceeding to develop Endless OS 4, likely to be released within the next few months.

For this version, we have undergone the distro maintenance improvements I described above, and as such we now have the latest podman from Debian (3.0.0-rc2) plus toolbox-0.0.99.

There are some awkward details there meaning that upon upgrade, all previous containers stop working and need to be recreated :frowning: we will document this in the release notes.

We also opened up our development ostree and I just published steps how you can try it.

thanks a lot for the progress update and the instruction for trying out Edless OS 4.
I guess I’ll try it with USB booting a clean install of a basic image …

One question, Will the 4 be more of the same, or will they have many significant changes? (apart from wayland, pipewire and gnome 40 etc)

sorrily, I do not succeed in Live USB boot. The basic configuration dialog of 3.9.3 does not terminate normally. The dialog gets stuck after/in WLAN config.

its now 5 months later, any news on that?

@btreut You can install the latest version of podman using the command:

flatpak install com.visualstudio.code.tool.podman -y

To run the Podman example:

flatpak --devel --command=podman -help run com.visualstudio.code.tool.podman

@LeandroStanger thanks for the tip, but I have some difficulty to folow your suggestion:

Searching for VisualStudio with AppCenter finds me also a standalone version of a podman 3.2.3 flatpak runtime. I tried that first, but it did not work, I get:

 flatpak --devel --command=podman -help run com.visualstudio.code.tool.podman 

  flatpak run [OPTION…] APP [ARGUMENT…] - Run an app

Help Options:
-h, --help Show help options
–help-all Show all help options

which is apparently the flatpak help, so I dropped -help from the command line and got:

$ flatpak --devel --command=podman run com.visualstudio.code.tool.podman
bwrap: execvp podman: No such file or directory

I installed the main package also, but there is not any change in the error message.

In some sense, it boils down to be very similar to my other open question (see How to run a bash using the ffmpeg runtime).

@LeandroStanger interestingly podman is also not found when I open a shell in VisualStudion and try in that shell a podman --version.

Working on it! Getting close to beta stages now.

1 Like

@LeandroStanger what do you want to tell me with

excellent news …