Problem installing anything (possible wifi driver problem)

Good evening.
I have reformatted lenovo yoga 14 and started using Endless. But after the first boot when I try to install anything from app center, I get an error that the app cannot be installed (tried chrome, retroarch etc.). Even when I check a YT video, it says there is no connection (wireless) but the icon displays proper connectivity. I tried restarting and using a script that a member post it for app installing problems (sudo eos-fix-ostree-repo) without success. After al this, I come down as my wifi card driver problem as a result. Could you please help me out? I cannot think of anything else at the moment and I want to use endless as I want to learn a little about Linux as I am a complete newbie. eos-diagnostic-200322_125034_UTC 0200.txt (1,2 MB)

It seems that some repos weren’t properly installed and after force update them, Chrome has been installed. Maybe there is an issue on wireless connectivity distribution. You can close this thread.
Thanks for your time.