Steam does not work


#1

Today my steam client stopped working. I removed and re installed it but still same. A few hours ago it was working. What happened? And i must download again all my library. I think i shold say goodbye to endless i am very annoyed.


#2

It says steam requires upper version of flatpak 1.0.0


#3

What version of Endless OS are you using?
To check which version of Endless OS you are in Settings :arrow_right: Details


#4

3.4.2-nexthw1 (180612-064059)


#5

Upgrade to Endless OS 3.6.3 from the App Center


#6

It does not update before i said its unable to update the entire system. Nothing happens. By app center.


#7
  1. Open the application called ‘Terminal’
  2. In this application run the command:
rm -f eos-fix-ostree-repo
wget https://raw.githubusercontent.com/endlessm/eos-meta/master/eos-tech-support/eos-fix-ostree-repo
chmod +x eos-fix-ostree-repo
sudo ./eos-fix-ostree-repo && flatpak update -y


#8

valve Requires upper version of flatpak error. Does not update.


#9

Ithink this system is not updatebale.


#10

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#11

Forget about it. I will install windows thats enough for me.


#12

My friend sorry but all of your solutions are the same


#13

Sorry you’re having issues. Helping users who are stuck on old versions of Endless is a priority and a fix should be released in the next few months.


#14

Sorry but how can i wait to play my games for a few months?? Till yesterday steam client was working well and suddenly stopped. Is it logical?


#15

You can try downgrading Steam using the instructions here: http://docs.flatpak.org/en/latest/tips-and-tricks.html

You would also want to disable automatic updates to prevent the downgrade from being undone. You can find the automatic updates menu by clicking on the battery icon in the bottom right corner of the screen.


#16
  1. Open the application called ‘Terminal’
  2. In this application run the command:
sudo flatpak update \--commit=\474cb9db7e88ba8cc1428beae5d758b76d3d77f41e182ef7e3239048181aab40 com.valvesoftware.Steam -y

#17

Same error

app/com.valvesoftware.Steam/x86_64/stable requires flatpak ver. (1.0.0) or upper.


#18

I think the endless os is incomplete os. Unable to meet users all needs. An application suddenly stops and impossible to troubleshoot. Best way is using windows again.


#19

If you can provide us a log, by following @LeandroStanger’s instructions above, then we may be able to troubleshoot.


#20

Sorry for the inconvenience here! There is a problem with versions 3.4.0-nexthw1, 3.4.2-nexthw1 and 3.4.3-nexthw1 where the upgrade process is not working quite right.

To recover from this situation, open the Terminal app and at the prompt, carefully type the command:
sudo ostree admin upgrade

It may ask for your user password (which will not be displayed as you type it in).

It will then go and download the update, so please be patient until the process finishes, it will say Bootloader updated; bootconfig swap: yes deployment count change: 1

At that point, reboot your computer and it will load the new version of Endless OS. Automatic updates will work from this point onwards and hopefully if you then install the latest Steam version it will work fine.