Unable to update endless Platform in my system

Also i have attached dignotsed

eos-diagnostic-200209_103517_UTC 0530.txt (2.4 MB)

  1. Open the application called ‘Terminal’
  2. In this application run the command:
killall gnome-software
flatpak update --appstream && flatpak update -y
gnome-software

Hi! were you able to solve the issue with the instructions provided by Leandro?

Hi @Byron_Diaz ,

I have run those command in but some of file are updated but Endless platform getting error

I have attached screenshots
Please help me out with this!!!

Thanks for the update.

Can you please try to run this command sudo ostree admin upgrade?

Hi @Byron_Diaz I have tried your provided command but it not worked form me.
I have attached some screenshots of this terminal.

Please check …

After running
flatpak update --appstream && flatpak update -y
command getting error for checksums as I have attached in privious screenshots

What happens if you open a Terminal and write:

eos-updater-ctl update

This should at first update your system to the latest one released (3.7.7 currently). After this, you normally should be able to upgrade either using the AppCenter or through:

flatpak update --appstream -y; flatpak update -y

If this does not work as expected, let us know so that we can further investigate your case.

Hi @egrath
I have tried your provided command but still getting error in updating

Please check

Also i have attached diagnosed report

eos-diagnostic-200215_140831_UTC 0530.txt (1.5 MB)

OK, you’re already at 3.7.7. Can you please run:

wget https://raw.githubusercontent.com/endlessm/eos-meta/master/eos-tech-support/eos-fix-ostree-repo
chmod +x eos-fix-ostree-repo
sudo ./eos-fix-ostree-repo

Afterward, try updating again.

Hi @egrath still I am getting same error while updating

Error pulling from repo: While pulling runtime/com.endlessm.apps.Platform.Locale/x86_64/1 from remote eos-sdk: Writing content object: Corrupted file object; checksum expected=‘bdfc5c9bccd6bd3fdb6c4c207b7060b28761f69c1801210e8715080a306c9b16’ actual=‘e1707e20fd993dfe27bb1db9f877212ee6f32ba2b3e49e33dcf996c9d44cb2c0’

eos-diagnostic-200215_155003_UTC 0530.txt (1.3 MB)

Hm … very interesting. To me it seems that there’s some problem in the remote repository, because when i uninstall the flatpak in question and reinstall it, i get the same error as you.

For now i did:

flatpak uninstall com.endlessm.apps.Platform.Locale/x86_64/1

which does not seem to impact anything in the system.

Error occured for above command

Leave the architecture and version away in the command:

flatpak uninstall com.endlessm.apps.Platform.Locale//

i have unninstall all

& during re install same issue occured again

If its remote repo issue so what time i can expect it can be resolved.

This is caused by Flatpak having become stricter about file permissions since these runtimes were built. The easiest workaround is to install them as root:

sudo flatpak update -y

However, it could be that you can simply uninstall these runtimes – most apps have moved to more recent versions which do not have this problem. Try:

flatpak uninstall --unused

Thanks @wjt updated successfully …

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.