USB installer doesn't work

I just tried downloading and installing the Basic 1.6 GB version of Endless to a 8 GB USB flash drive. The drive is new, especially purchased for this purpose. I tried several times in different ports to run the installer, but each time it failed with an error at about 6%. After it failed, the drive was unusable and could not longer be correctly formatted. The first partition would format to about 60 MB, but the rest of the drive could not be seen or restored by the OS. To check if the drive was faulty, I had to use low-level partitioning software to remove everything Endless had placed on it. Once I did that, I was able to format the drive normally. As a test, I tried copying several hundred megabytes of random data to the drive and that worked fine, so the drive is not faulty. After that test I tried installing Endless one more time and got the same error. There is clearly something wrong with this software.

1 Like

Hi Rikki, yes, clearly you’re hitting a bug in the Installer. Can you upload the log files here so I can take a look? I suspect this is a known issue that I’ve not yet worked out how to fix :frowning:

1 Like

Thank you for your reply. I will try to upload one of the log files here.
EndlessInstaller20170503_11_33_36.log (718.4 KB)

1 Like

Hi Rikki,
Until there is a solution you can try to build a stick as follows:
Step 1
Download the tool Rufus for building a Live-Stick and i.e. 7Zip to unpack the image that was downloaded by the endless-installer.
Step 2
Unpack the endless-image from the xz- file “eos…xz”. You will get a img-file with same name.
Step 3
Plugin your USB.Drive and start the tool Rufus.
You have to choose GPT for UEFI as partition scheme, if you have W10 installed in UEFI-mode.
If there are Problems in booting try the other options.
Change the image-setting from ISO-Image to DD-Image and choose the unpacked eos…img for building your stick.
Step 4
Change Bios-Settings for booting your stick, leave Secure-Boot enabled.
Endless-OS should now boot.

Additional tip for reformatting your stick:
With the SD-Formatter-Tool it is no problem to format a stick after such breakdowns. All partitions will be deleted an the stick formatted in FAT32.

Greetings and have fun with your new OS.

1 Like

Thanks for this suggestion @AlexP – bear in mind that if you create a USB stick in this way, it can’t be used to install Endless OS, though you can use the USB stick to try Endless OS. A similar workaround if the Endless Installer for Windows isn’t working is to download an ISO image from the Linux/Mac tab on and write that to a USB stick in DD mode with Rufus – a USB stick created in this way can be used to try Endless OS, to reformat a PC with Endless OS, and to install dual-boot with Windows.

@Rikki Here’s the failure in your log:

12:34:32 - EndlessUsbToolDlg.cpp:4773 CEndlessUsbToolDlg::CreateCorrectPartitionLayout
12:34:32 - EndlessUsbToolDlg.cpp:4805 CEndlessUsbToolDlg::FormatFirstPartitionOnDrive
12:34:32 - Waiting for logical drive to reappear...
12:34:32 - Quick format was selected
12:34:34 - MSG_218 UNTRANSLATED
12:34:34 - Error while formatting
12:34:34 - Operation OP_CREATE_FS(5) with progress 100
12:34:35 - Quick format was selected
12:34:42 - Quick format was selected
12:34:48 - Quick format was selected
12:34:55 - Quick format was selected
12:35:00 - EndlessUsbToolDlg.cpp:4821 Format error. (GLE=[0])
12:35:00 - EndlessUsbToolDlg.cpp:4672 Error on FormatFirstPartitionOnDrive (GLE=[0])

I’ve seen an error a bit like this before but not normally at this point. If you have the time and inclination, can I ask two favours of you?

  1. If you’re happy to run a pre-release version of the Installer, could you download the .exe file from this branch and try creating a USB stick with it? If you download it to the same folder as the existing copy of the installer – and image it downloaded – you won’t have to download the OS all over again. Let me know if it works; if it doesn’t work, please attach the latest log file here.
  2. Can you download Rufus and try to format your entire USB stick with GPT partition scheme and exFAT filesystem?
1 Like

Hi Will,

I used the debug installer and it worked fine. That is, it created the USB without any problem or error. However, when I tried to boot, I had a different error. There was no way to capture an image of it so I tried photographing it with my Android device. Unfortunately, the photo is very poor quality but you might be able to make it out well enough to see what it is saying.

I was hoping to find a solid and reliable Linux version that would be easy to use, but these errors tell me that Endless is not yet a stable product. I think it is a great idea and I wish you well, but I am not prepared to invest any more effort in this. I am elderly and I no longer have the patience or energy to do development work.

Good luck and I hope you manage to solve the problems with this.


1 Like

Hi @Rikki, sorry that didn’t work out. Can I ask just one more favour of you – could you upload the log generated by the debug installer, please? It’ll help me verify whether the fix is correct, or whether it introduced this new problem you see. Thanks!

1 Like

EndlessInstaller20170509_11_24_25.log (402 KB)

1 Like

I’m also having problems installing Endless OS to a USB stick. I’ve tried 3 brands already, Sandisk, Transcend and Adata. They all report the (oops!) within 2% after the verification stage window. I’ve downloaded the full package of EOs 3.3.3. I’ve also tried it on 3 notebooks and 2 PCs. even on a freshly formatted Win10 core i7 PC. But interestingly enough, it can install the OS without any problems. and can dual boot. My question here is: Is the installer looking or choosing a specific USB brand?

Hope the developers here can help…

@Ottid888 no it’s not brand-dependent as far as I know. Can you attach the log files created by the installer here?

I’m currently downloading the new version (3.3.4)
. will get back to you if i still encounter the
same problem when installing the OS to the USB.


At 04:49 PM 11/27/2017, you wrote:

Hello Will,

finished downloading 3.3.4 and still the same,
when it comes to writing to the USB, at around 2%
it spews out the error and can’t continue.

I hope you guys can find the problem and make it
work. i’m getting exasperated
already… attaching the 9mb log file (zipped)

thank you.

At 04:49 PM 11/27/2017, you wrote:

Hi, the log was not attached – please try attaching from the website rather than by email.

Hello there. Attaching the log file here…EndlessInstaller20171127_10_14_57.log (9.2 MB)
Hope you can find the cause why it fails to install to the USB stick at 2%…

thank you very much.

Hello? Do we have any reply for my problem pls? Still can’t install to a USB stick… keeps on giving out an error after just 2% of writing… this is really getting tiresome…:tired_face:

Trust me, it’s also tiresome for me that whenever I squash one USB creation bug, another one pops up.

Try downloading this slightly older version of the installer to the same folder as the current copy, and try creating a USB stick with that version. You should not need to redownload the Endless OS image files.

1 Like

Yes!!! Was finally able to make the USB installer disc with the installer file you just gave me. Thank you very much! Now to download those other codecs to be able to play .mkv files… :rofl:

By the way, how do you keep your bluetooth setting hidden while it’s turned on? Thanks.