App Center doesn't show any applications


#1

App Center only shows the message: “No application data found” and only System Applications are shown in Installed applications.


Endless 3.7.1

eos-diagnostic-191023_183554_UTC-0300.txt (277,7 KB)


No application data found - App Center Error
#2

Hi @joseanderson95

I would need some more debugging information regarding our app-center.

Can you please follow these steps as mentioned here.

  1. Open Terminal
  2. Run killall gnome-software
  3. Run gnome-software --verbose > gnome-software-verbose.txt – this will launch the app center and gather a lot of debug output to a text file
  4. Reproduce the problem in the app center (See if apps are still invisible in this case)
  5. Close the app center and return to the Terminal
  6. Press Ctrl-C
  7. Send gnome-software-verbose.txt to us

#3

gnome-software-verbose.txt (450,0 KB)


#4

This problem has been occouring since upgrade to 3.7.0.


#5

Any solution? Upgrade to 3.7.3 didn’t solve this problem.


#6

Hi @joseanderson95

We are still looking into the debug log you posted. I would require more actions from your side. Basically give file information for the paths. So:

  • Open Terminal
  • Type and run the following 4 commands:
  1. ls -al /var/lib/flatpak/appstream/eos-apps/x86_64/active/appstream.xml.gz
  2. ls -al /var/lib/flatpak/appstream/eos-runtimes/x86_64/active/appstream.xml.gz
  3. ls -al /var/lib/flatpak/appstream/eos-sdk/x86_64/active/appstream.xml.gz
  4. ls -al /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz

Can you please post the output of the these commands here?

Also, it might be worth to run flatpak update --appstream in terminal and restart the system once again.

Let us know your findings.
Thanks.


#7
$ ls -al /var/lib/flatpak/appstream/eos-apps/x86_64/active/appstream.xml.gz
-rw-r--r-- 1 root root 120520 Oct 23 17:18 /var/lib/flatpak/appstream/eos-apps/x86_64/active/appstream.xml.gz
$ ls -al /var/lib/flatpak/appstream/eos-runtimes/x86_64/active/appstream.xml.gz
-rw-r--r-- 1 root root 101 Sep 25 15:12 /var/lib/flatpak/appstream/eos-runtimes/x86_64/active/appstream.xml.gz
$ ls -al /var/lib/flatpak/appstream/eos-sdk/x86_64/active/appstream.xml.gz
-rw-r--r-- 1 root root 613 Sep 25 15:12 /var/lib/flatpak/appstream/eos-sdk/x86_64/active/appstream.xml.gz
$ ls -al /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz
-rw-r--r-- 1 root root 2276898 Oct 24 08:43 /var/lib/flatpak/appstream/flathub/x86_64/active/appstream.xml.gz

#8

Doesn’t solve the problem.


#10

We were still not able to reproduce the issue, but one other thing you could try to see if it helps would be to remove the cache from gnome-software as follows:

  1. Open Terminal
  2. Run killall gnome-software
  3. Run rm -rf $HOME/.cache/gnome-software
  4. Run gnome-software

Please let us know if that helps.


#11

same with me.
eos-diagnostic-191030_194920_UTC 0800.txt (1.0 MB)

gnome-software-verbose.txt (2.0 MB)

send help…


#12

Hi @joseanderson95, did you have the chance to check about removing the g-s cache? If that doesn’t solve the problem could you please provide us with the contents of your /var/cache/app-info. You can get it with:

$ tar cf app-info.tar /var/cache/app-info

Then send us the generated app-info.tar file. Thanks.


#13

i have the same problem but all above have not worked

gnome-software-verbose.txt (450.0 KB)


#14

Could you please try removing /var/cache/app-info/xmls/org.gnome.Software-eos-extra.xml.gz to see if it solves the issue. To do it run:

  1. Open terminal
  2. Run killall gnome-software
  3. Run sudo rm `/var/cache/app-info/xmls/org.gnome.Software-eos-extra.xml.gz
  4. Run gnome-software (it should redownload the file above)

After item 4 above you may need to stop/start gnome-software again (2 and 4).


#15

somehow, it still doesn’t work sir.


#16

Thanks for checking. We believe to have found the cause of the issue (the version of libxmlb) but we don’t have any workaround atm. We are planning to include a fix in the next version, still to be confirmed though.


#17

after step 4, it doesnot redownload the file, meanwhile no change.


#18

how can i downgrade so that i can still use the functioning version on my laptop? or how can i install an app on terminal ? i just need to install vlc. thanks


#19

#20

sorry sir the real problem is i cant use the app center because it does’t show any more apps. the only app i need is for now is vlc. so for now giving access to install vlc without using app center will make me happy. thanks


#21
  1. Open the application called ‘Terminal’
  2. In this application run the command:
flatpak install flathub org.videolan.VLC -y
flatpak update --appstream && flatpak update -y
eos-add-to-desktop org.videolan.VLC
flatpak run org.videolan.VLC