AppCenter closes after startup

eos-diagnostic-200607_101136_UTC 0200.txt (921,2 kB)

It is nice to be here.
I tried to solve it based on the description,
Please help me.

  1. Open the application called ‘Terminal’
  2. In this application run the command:
killall gnome-software
flatpak update --appstream && flatpak update -y

Are you using a computer that came with Endless OS preinstalled?

Yes, this is it.
It worked well.
Can I fix it?

Sorry you’re experiencing issues. I created an internal ticket for this issue and I’ll look into it.

@Erika_Eles-Varga hi, can you open a Terminal window again and execute this command:

flatpak update -vv 2>f.log

Then follow the prompts if it asks you to update anything, and post here both a screenshot and the file f.log which will be in your home directory.


Thank you f.log (23,0 kB)


You can likely fix your issue by executing this in a Terminal window: pkexec flatpak repair

Just enter your password if you have one set and wait for it to complete, at which point you’ll get a prompt ending with a $.

I also have a fix that will hopefully be in the next OS release. Thanks for reporting the issue!

Thank you for your help. I completed the task you suggested, it seems to work. Than I updated again in terminal, there were several packages to install. It seems okay.
Thanks again!

1 Like