Asus doesn't connect to wifi after sleep

Hi all,
in the past few days I’ve been having problems with reconnecting to wifi after sleep. I need to restart the laptop for the wifi to work, every time. Tried what was suggested in this forum for this problem, rolled back to previous version, but the problem persists. Any help would be appreciated.

eos-diagnostic-200516_210112_UTC 0200.txt (915.0 KB)

Hi!

Please verify this post Wi-Fi not working after upgrade to 3.8.0

Hi,
Thanks for your answer. I did everything in that post up till the “completely reset your wireless network” part; after that one my problem is different than his, as he’s getting “permission denied” problems, which I didn’t get. The system is now rolled back to the previous version, but wifi still doesn’t connect after sleep, only after reboot.
eos-diagnostic-200517_120522_UTC 0200.txt (840.0 KB)

anyone please? I upgraded to the new release, hoping it will solve the problem, but still doesn’t connect to wifi after sleep. It’s quite inconvenient to restart my laptop each time I need wifi, as I have to reopen lots of apps for my work…
eos-diagnostic-200521_211231_UTC 0200.txt (1.5 MB)

Hi!

It sees like you have to update your BIOS, please verify with Asus about this.