Battery drain while suspended


#1

Hello! I am using Endless OS 3.6.0 on an Asus X540MA (Pentium N5000) and I am experiencing a battery drain when the laptop is suspended. It looks as if it does not enter deep sleep state. Is there a way to force it?


#2

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#3

Here is the log:
eos-diagnostic-190623_092352_UTC 0300.txt (847.8 KB)


#4

From what i saw in the logs, it seems your systems goes out of S3 sleep a few seconds after entering it. As a first attempt, i would recommend you to update to the latest BIOS (3.07 at the moment) and check any power related BIOS settings.


#5

Just updated the bios but from the log it does not seem to make a difference:
eos-diagnostic-190623_155957_UTC 0300.txt (715.9 KB)


#6

can you please post the output of:

cat /sys/power/mem_sleep

if there’s [s2idle] displayed, can you also try:

echo deep > /sys/power/mem_sleep

and then put your device to sleep


#7

The first command shows “s2idle [deep]”, but the second one ends up with a “bash: /sys/power/mem_sleep: Permission denied” message.


#8

Ok, it’s already in the correct state [deep]. Hm… good question, have you checked the BIOS settings too?


#9

Nothing there - the Asus bios is pretty barebones even in “advanced” mode…


#10
  1. Do you have any externally connected devices, like a wireless Mouse? If yes, can you please disconnect them and try again
  2. Can you please temporarily disable bluetooth and try again.
systemctl stop bluetooth

#11

Not sure if there is any difference - actually I think there is none :frowning: . Here is the log: eos-diagnostic-190625_075512_UTC 0300.txt (779.9 KB)
A friend of mine suggested to add an actual swap file to the system as systemctl hibernate returns “Failed to hibernate system via logind: Not enough swap space for hibernation” error. Unfortunately, even with a 8GB swap file (for a 4GB RAM system) the result was the same after a restart (actually hibernate shut the system down completely which was also not desirable) so I reverted back to the default config (with 5,5GB ZRAM).


#12

Bump, bump, bump… :slight_smile:


closed #13

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.