Beta Release | Endless OS 6.0.0~beta1

The first beta release of Endless OS 6 is out! Please follow these instructions if you want to join the beta testing program. Bear in mind that the chance of encountering bugs in a beta release is higher than in a regular release – please ensure your data is backed up before updating.

Endless OS 6 will bring a lot of changes and improvements, which are detailed in draft form in the Draft Release Notes. Most of the changes listed there are already present in the 6.0.0~beta1 release.

As a beta tester, you can help us by providing feedback on stability and hardware support, and reporting software regressions (things that used to work in previous releases that stopped working on this new release).

1 Like

Note that you won’t be able to automatically update to 6.0.0~beta1 until the forthcoming 5.1.3~beta1 release is published. We’ll post here when that is the case.

Now the automatic update should be possible.

If you’re running Endless OS 5, please help to test this change by ensuring you are on the beta channel then checking for & installing the OS update to 5.1.3~beta1 in the App Center. After rebooting you should be notified of a major update to Endless OS 6 in the App Center.

Thanks @wjt for clarifying.

1 Like

Hi, i do the upgrade as you talked on post, but now I can’t run many applications, like browsers or libre office, and can’t run eos diagnostic because the terminal is not running too, what could I do?

Good morning, after a lot, I got the terminal to work so I could run the eos diasnostic; After updating to the Endless 6 beta, several applications are not working (not running), and I would like some help to solve this problem.

eos-diagnostic-240413_092827_UTC-0300.txt (1,8 MB)

@James_Martinez thank you so much for testing and contributing the diagnostic! The team at Endless is investigating the issue. One initial guess is that your system is running out of memory while applications are being updating, so any application that launches is being stopped right away (by the OOM killer). If this is the case, your system should be back to normal after the update is done in the background. But it shouldn’t happen in any case.

@James_Martinez could you help with a little debugging? The bottom of the file /etc/gdm3/daemon.conf reads:

# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes

Can you change that so Enable=true is uncommented like this:

# Uncomment the line below to turn on debugging
# More verbose logs
# Additionally lets the X server dump core if it crashes

You can run sudoedit /etc/gdm3/daemon.conf to do that. After that, please reboot, run eos-diagnostics and upload the diagnostics file again. Thanks!

Dan, Hello, I don’t know if I have done things as you have indicated, but here is the new diagnosis; If I can help, I will be attentive.

eos-diagnostic-240415_195117_UTC-0300.txt (1023,4 KB)

Just to give you some background as to what may be happening: it seems that the system believes it is running out of memory, and hence it is preventing some further apps from starting (or terminating ones that were already running).

Your system has 4GB RAM and you are simultaneously running some apps that can be quite large, like Chrome, Floorp, Firefox, Zotero and Libreoffice, so it is not unthinkable that you could be exceeding available resources.

In any case we are doing some analysis to understand if the system is truly out of resources or not, as we do have some other reports of unexpected results in this area. It would be really useful if you have any comments on whether this behaviour seems new to you in EOS6, i.e. does the same set of applications work simultaneously under the previous version EOS5.1?


It really is a behavior that I had not had in previous versions of Endelss, in addition, I have run several applications at the same time (libreoffice, librewolf, ImageJ, among others), without any failure in the resources, in this case, in endless 6 not even I can start applications, such as browsers, in any case I am available to continue sending information.

Thanks for the info. Could you please run this command, and see if it makes any noticable difference to the situation:

echo 'n' | sudo tee /sys/kernel/mm/lru_gen/enabled

(This adjustment will only apply to the current boot. On reboot, the original behaviour will be restored.)

Alright, I have run echo ‘n’ | sudo tee /sys/kernel/mm/lru_gen/enabled, and I have tried different applications but the same problem still exists, none of them start or it takes a long time to start. I performed the test without rebooting the system.

Please retest for this app-killing issue with the beta2 release (should be available as an automatic update)

13 posts were split to a new topic: Wayland session crashes and falls back to X11