Booting EndlessOS fails

My EndlessOS is unbootable. If I try to boot normally, it hangs on the second splash Screen (1st: Acer, 2nd the infinity symbol for EndlessOS). I forcedly switched the notebook off and retried booting two times without any Change, then, during the third boot attempt, I hit F12 for getting verbose boot messages. I succeeded in making some screenshots with my mobile phone, which I include here: they were taken as can be seen in the file names at the local time
11:52.43:


11:53.12:

11:53.35:

12:01.28:

12:21.24:

13:02.55:

13:11.33:

13:16.38:

There are several ugly error messages and finally it is stuck in an endless (!) loop tryimg and failint to Start a service: Failed to start Accounts Service

I cannot attach the eos-diagnostic log file since it does not boot. If it makes sense, I would be able to boot another Linux from USB (Q4OS, yet another Debian Bullseye derivate), I can offer to do that and I might be able chroot into EndlessOS file system to create the eos-diagnostic, but on the one hand, I don’t know, if this makes sense and on the second hand I would need some help in doing that.

Any help in repairing is welcome. As noted, I could boot another Debian for file system repair. I recently (see How do I add myself to the group input?) duplicated the input group in /etc/group, but I rebooted several times since then without apparent problems, so I doubt that this might have caused the boot problem.

You should be able to switch to VT2 at this point (Alt-F2), then log in and run:

sudo journalctl -u accounts-daemon

Please make a photo of the output.

I had tried switching to a another console but there was no login prompt, only a black screen …

OK, have to work out a exact procedure on how to extract the necessary logs with a live USB - but will take at least until monday when i get back home.

thanks in advance. I will be away from the system between next Monday and Friday …

Hello Btreut,

I had some problems at start up too. If you still have your USB key used to setup endless OS, you can also use it for repairing purpose ; see option 1 from this tutorial : https://support.endlessos.org/en/troubleshooting/boot-into-emergency-mode

Hope that could help you :slight_smile:

thanks. This is a laptop, which came with EndlessOS preinstalled.

@Zerooky: the link you provided suggests to fsck the ostree partition. since I am able to boot another Linux, I did a fsck of the ostree partition from there and it found lots of errors. I allowed fsck to correct the errors, although I do not understand where these errors came from.

fsck of the system partition solved the boot problem … this post is now from repaired EndlessOS, previous post 7 was from Q4OS.

Great to read you solved it !
Thanks for the feedback, it’s good to learn how you made it work.