Brand New Laptop, but no space on my HD? Need help! (Newbie here!) EDIT: SOLVED! :D


#1

Hi all! I am so glad I found this community.
My windows laptop died while I was travelling. I purchased a new lappy, with Endless 3.6.1 installed. However, I’m already getting an error message, and it seems my root folder is already 99% full. No clue how, or what to do. I’m a complete newby, so I need someone with patience to help me out. I want to learn Linux and there is no better way to learn that needing to!

First off, I should have space, right?! My HD is a 250 Gig SSD drive, with only Endless installed AFAIK.

When I ran my df in the terminal, it says that it’s the sysroot folder which is full…here is what I get;

Filesystem 1K-blocks Used Available Use% Mounted on

devtmpfs 1930676 0 1930676 0% /dev

tmpfs 1988268 237080 1751188 12% /dev/shm

tmpfs 1988268 12404 1975864 1% /run

tmpfs 5120 4 5116 1% /run/lock

tmpfs 1988268 0 1988268 0% /sys/fs/cgroup

/dev/sda3 29861648 29252280 352836 99% /sysroot <— problem??

tmpfs 1988268 4 1988264 1% /tmp

tmpfs 397652 88 397564 1% /run/user/1001

/dev/mmcblk0p1 15424512 1055104 14369408 7% /run/media/ *deleted computer name for privacy)/BAD6-A637

Help? I really need someone to take me step by step cause this is all new… <3 Thanks!


#2

Just a quick update after checking out some other posts;
I ran:
ostree admin undeploy 1
which freed up some space, so now my root folder is at 91% full, which is good, but I should still have a heck of a lot more space, right?
Thanks again for any help!


#3

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#4

Hi! thanks for your help, I’ve actually solved the problem on my own!
For some reason (I think I know why…) the partition was made small, and there was 203 gigs of inaccessible HD space. Basically, I just expanded the partition and it is fixed!

My assumption, based on the fact that the seller of the laptop offered to install windows on it for an extra 150$, was that most of his clients either want windows, so he simply installs the partition smaller until he installs windows…or (if I believe some people are bad…) he purposefully installs in this manner so the customer returns frustrated, and asks for a windows install.

Either way, my problem is fixed! I am still very happy to be part of this community as I still have a lot to learn!

Thanks for your help though :slight_smile:


#5

Thanks a lot for your interest in Endless, your feedback is very welcome!

So you are under the impression that the seller personally installs Endless on the products? If you happen to have an email address contact there, I’d like to reach out and see if we can help them solve that problem. Feel free to send me a private message with the contact if you have it.

The Endless installation process does start by installing a partition setup with very little free space, but it is then designed to automatically expand. However, sometimes, particularly when people deviate from our standard installer and use their own e.g. disk-cloning solution for setting up multiple installations at the same time, that detail gets skipped. I suspect something accidental like this is happening here too.