Broadcom driver problem

Hey. OK folks?
I’m having problems with my hardware
Broadcom “BCM4313”
It doesn’t work as it should. It’s almost impossible
use the internet with the adapter.
In previous versions of the Operating System it worked correctly. But now it’s very slow and it takes me hours to download updates to my computer and browsing is very, very slow!

I saw that an update came out for Realtek. Can you do an update to solve the problem of this Broadcom driver as well?

Thanks.
Homero Bretas - Brazil

Can you please provide us with a diagnostic taken when the issue occurs. Open Terminal, then run:

eos-diagnostics

Upload the generated file into this thread for further analysis.

1 Like

Can you please open a Terminal, then enter the following command:

cat << EOF | sudo tee -a /etc/modprobe.d/blacklist.conf
blacklist b43
blacklist ssb
EOF

Does that make and difference? When has it worked last time? EOS 4.0.9 has been released a few days ago. If the above does not fix the issue and it worked a few days ago, please also let us know.