Cannot apt-get-install anything

As per title. I followed all of the other forum hints and nothing has worked so far. I use endless for work and I really need to apt-get install a lot of things that are not otherwise available via flatpak & co.
Would be amazing if you could help :slight_smile:

Best of all would be to be able to use all the “regular” commands (I have seen the explanation why they are not immediately available…but are they at all?). Is it possible?

eos-diagnostic-201110_174032_UTC 0100.txt (869.7 KB)

You can’t. Endless OS is built around the Flatpak technology to provide it’s application stack. You have multiple choices:

  • Build a Flatpak of the application you need and publish it to Flathub
  • Use toolbox to run a instance of Fedora inside EOS (hint: toolbox create, then toolbox enter)
  • Use Podman directly to run any Docker provided Distribution image (like Ubuntu) in EOS. This one will give you the commands you are used to, like apt. See Running Ubuntu with Podman for further details

Thank you for your answer! Unfortunately this is not enough for me.
While I loved working with Endless briefly, everything I need to do turns into a headache this way.

I first found it because I was experiencing problems installing Ubuntu over Windows 10 due to RST. Reaching for Endless OS seemed to solve the issues immediately. However it turns out it does not meet my needs and now I am struggling to find another alternative that would work. I know you don’t need to answer this, but do you have any suggestions?

What application are you missing from EOS and want to install with apt?

I need the packages I use for work daily and are not available for Endless OS. I’m a backend developer. Frankly any attempt with Podman was not successful for me, but even then, I would just like to have an OS running as “normally” as I am used to without having to resolve to such things :slight_smile:

In this case, take a look at Pop! OS.

Is it going to not present problems even when dealing with RST?

I don’t know, just try it :slight_smile:

I did, unfortunately no luck. Thanks anyway :slight_smile:

Why don’t you simply disable RST in the BIOS? RST is only needed if you have multiple disks in your PC and want to make them work as a RAID array…

I have tried that first thing – but I have no option to pick AHCI and therefore my hard drive is just not visible when trying to install another OS. It is an issue I saw online a lot I have tried to install 5 different OSs – Endless (and Windows 10) are the only ones that manage to complete installation :slight_smile:

Holy, just checked google. The Dell support forum is full of people complaining about the inability to install most Linux distributions cause of this … :frowning:

yes exactly! Thank you for checking! In this case, Podman or Docker it must be.
Speaking of which, I don’t know whether this is the right place, but I am getting new problems.
I have tried Podman following your instructions. However so far even within the container I fail to run very simple commands such as apt-get install curl, where I get stuff like:

debconf: delaying package configuration, since apt-utils is not installed
dpkg: error: requested operation requires superuser privilege
E: Sub-process /usr/bin/dpkg returned an error code (2)

If i do apt install apt-utils I get the same error, and of course doing it all with sudo does not work :slight_smile: With other simple commands, the package simply seems not to be located. Any tips? :slight_smile:

EDIT: it worked with

podman exec --interactive --tty mycontainer /bin/bash

so far