Can't run autorun.exe

I’m trying to install a wifi adapter but it says that it isn’t possible on endless , and that there are apps for it in the app store. Yet i can’t find anything to install it. The whole system is up to date , so my question is what do i need to do to install the wifi adapter?

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

eos-diagnostic-210401_144814_UTC 0200.txt (1,2 MB)

Have you tried going in Settings :arrow_right: Wi-Fi

Yes , I tried going to settings/wifi but i can’t connect to my wifi nor can i run the file i need to install for the wifi adapter

Hi @anna.soer02 - the drivers you have are for the Windows OS and are not compatible with Endless OS. In Endless OS, all of the drivers for the supported hardware are built in to the version of Linux that we include with OS, and (although it’s possible using other Linux-based systems) we do not support installation of external drivers for reasons of quality and security.

It looks like there is a driver for your wireless adapter built in to Endless OS, but it seems not to be working properly. Effectively this means your wireless adapter is not compatible with Endless OS - unless/until the manufacturer invest the necessary time to have their hardware properly supported by Linux. The simplest way forwards may be to exchange the wireless adapter for one with better quality Linux drivers - this webpage lists some USB wireless devices which work with Linux and are more likely to work on Endless OS systems - https://linuxhint.com/linux_compatible_wireless_network_adapters/