Chrome pixelated after returning from standby

Hello! Ever since I bought my laptop I had this problem with Chrome being pixelated after returning from standby. It happened every time so I send it in service to fix it but they sent it back and told me that is a problem from the operating system. Can you please help?
Thank you!

1 Like

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

eos-diagnostic-201011_143225_UTC 0300.txt (872.6 KB)
Thank you!

  1. Open the application called ‘Terminal’
  2. In this application run the command:

flatpak repair


I did what you told me but the problem remained. Also, usually, it happened only to Chrome. After I ran flatpak repair the problem extended as you can see in the picture :upside_down_face:

Upgrade to Endless OS 3.8.7 by App Center
support.endlessos.org/help-center/How-often-is-Endless-OS-updated

Hello again :slight_smile: I updated the OS but i am still experiencing the same problem. Do you think It could be a hardware problem? Should i send it back to the service?

Hi,

Your system has a nvidia graphics card and unfortunately there is a deficiency in nvidia’s Linux driver support that can cause this to happen some times on some computers.

There is some kind of strange technical mechanism available that might or might not help this, but it would be hard to integrate into Endless, and nvidia did not reply to my request for clarifications below.

One thing you could try here is to blacklist the “nvidia” driver module so that the unofficial nouveau driver is used instead, which may have lower performance and functionality but should avoid this issue. (apologies that I don’t have time to give a more useful link right now, maybe someone else can jump in and explain?)

1 Like

In general, there are two drivers for NVIDIA cards currently available and actively maintained:

  • The proprietary NVIDIA driver which has great performance but some other issues, like reinventing the wheel, being propiertary and not supporting older chips
  • The free Nouveau driver which is developed by the community, but lacks support for some of the newer cards, lack of some features some might need and some other issues.

Normally, when both drivers are installed, the proprietary driver is used if not otherwise told. To force the Nouveau driver, open a Terminal and run:

echo "blacklist nvidia" | sudo tee /etc/modprobe.d/blacklist-nvidia.conf

When done, reboot your computer and see if the problem still persists and let us know.

2 Likes

Hello Catalina_Antal,

I found a quick way to switch to open-sourced Nvidia driver,

  • Turn off your then power on the system
  • Press ESC before the splash screen(and jump into GRUB menu)
  • Press e key to edit the entry
  • Then add this to the end of line of linux parameters
    • modprobe.blacklist=nvidia systemd.setenv=GPUMOD=nouveau
  • After finish typing press F10 to boot

This is one-time setting change, but if something went wrong, just reboot your system it will go back to default.

This is a bit tricky, let me know how it works and I might able to get some screenshots later.

Refs.:
https://wiki.archlinux.org/index.php/nouveau
https://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching

Let’s see which method will work, egrath, thanks!

Thank you very much! It worked! :smiling_face_with_three_hearts: