[cli install] Flatpak Icons on desktop?


Love the OS, its perfect for my kids. I have a usecase where I want to install a flatpak to an external drive so that we can limit access to certain games by unmounting the drive.

I have installed the flakpaks via the CLI using the --installation=<flatpak config name> and that works great. I can launch the apps via flatpak run <flatpak id>. However, for the life of me I can’t figure out how to get the icons to show up so the kids can launch the apps on their own

I tried putting the .desktop files in ~/.local/share/applications, I tried sym-linking them into where the other flatpaks are installed. I have tried running the gnome tooling to update the desktop files via the gnome documentation. I have done the alt +f2 +r shortcut, I have rebooted, logged out.

I’m hoping someone has a really quick/simple answer and that I just missed something easy.

How do I either manually create desktop icons or link the flatpak from the USB into the correct location so the icons will be picked up?


I found a hack around this eventually.

I used systemd-x mount options in the FSTAB to make sure the USB drives always mounted to the same location.

Next I installed the flatpak to the USB drive as seen in the flatpak github.

Finally, I went into /ostree/deploy/eos/var/lib/flatpak/app and sim-linked all of the flatpaks on the usb drive. If you restart the desktop alt + f2 + r the icons may eventually show up on the desktop. Ejecting the USB drive leaves the icons broken which is just fine for me

Also as a side note, after I did this there are now 2 entries for everything inside of the App store regardless of whether they have been installed or not. Selecting the first occurance of an app and installing that will install it to the normal location, whereas installing the second version of the application in the App store listing will then install it to the USB drive.

I find this all very curious

You need to add $INSTALLATION_PATH/exports/share to the $XDG_DATA_DIRS variable.

If you have defined the installation in a file in /etc/flatpak/installations.d then this should happen automatically.

In all likelihood the USB drive will have to be connected before you start the desktop.

At least on Endless OS 5, App Center is meant to group these together, with a little dropdown to pick which installation to use. I have Flathub configured in my user installation and in the system installation, so I see:

Run the following command in a Terminal window – what do you see:


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.