Custom build problem with 5.0

We have been successfully doing custom builds for EOS 4.0. I tried doing the same build for 5.0 and got the following error message:

fatal: detected dubious ownership in repository at ‘/sysroot/home/owner/eos-image-builder’
To add an exception for this directory, call:

git config --global --add /sysroot/home/owner/eos-image-builder

I tried the recommended git command end then reexecuted the command:

sudo ./eos-image-builder eos5.0 --personality en --use-production-ostree

with the same result.

Note when I did the original checkout, I executed:

git checkout eos5.0

Any guidance on what to try next?


Where does the build fail when you do this? Can you paste or attach a log?

Also, I presume you have to run sudo git config --system --add /sysroot/home/owner/eos-image-builder so it’s set in /etc/gitconfig rather than the user’s ~/.gitconfig.

That did not help, I still get the same error. Attached is a log of the build.
Build_Log.txt (758.6 KB)


Right, that’s the one place in the builder where it actually uses git. You’re in a separate root at that point, so whatever git config you used on the host is not referenced.

I can think of a couple potential fixes:

  1. Inside the buildroot, set the repo as a safe directory.
  2. Ignore failures as the data isn’t that important.
  3. Gather the git commit at the beginning so the host’s safe directory settings apply.

To keep going, you can just comment out the builder_commit=$(git rev-parse HEAD) line in stages/eib_manifest. Unless you’re using that data from the generated manifest, you won’t be losing anything.

If you want to try the change from, it implements the 1st option. That worked for me locally.

I got the build to work by commenting out the builder_commit line so all is good.


Never mind I found MY problem.


I am still seeing the unauthorized git directory problem - I did a test build this AM and the problem was still there (build log attached).

I can work around this by commenting out the line in stages/eib-manifest and indeed this seems to speed up the build while still giving me a usable ISO.

I am writing up the build instructions for 5.0 and need to know, should I include the edit of stages/eib-manifest as a permanent step in the instructions or will some future release not require it? It was not required for 4.0 builds.


build_log_3.txt (759.1 KB)

I just merged the change Dan linked to above:

to the master and eos5.0 branches of eos-image-builder. Can you git pull and retry?

Are you no longer using the kramden-image-config repo we set up?

I just tried a new 5.0 build and it worked without the edit of stages/eib-manifest. Thank you all is good now.

We have had a recent turnover in personnel and the person you worked with to establish the kramden-image-config repo is no longer with Kramden. I am just now aware of its existence and will look into it. I have been doing the production builds for about the last year or so and the former employee was looking at deploying Endless from a server.


1 Like

Thanks for the confirmation!

Good to know. Someone on our team is tentatively exploring network-installs using Clonezilla at the moment. Are you able to share the details of what you use for network installs of other OSes?

Right now, the only OS we are installing via internet is Windows.

I tried doing a 5.0 build using the Kramden Repo mentioned above and a lot of apps are missing in the final build. For example the Learn directory should contain 10 apps but only contains one (Kolibri). The Health directory is completely missing. It seems apps beginning with “com.endlessm” are not being found.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.