Didn't boot up properly after updating to 5.1.0 and built-in touch pad not working

eos-diagnostic-231202_095247_UTC-0300.txt (1,1,MB)

Hi, new user here, yesterday i tried updating Endless OS (5.0.6 -> 5.1.0) through the app center, my laptop restarted but it was stuck in the ACER bios boot screen for about an hour, i didn’t know what to do and had not found answers online so i decided to force shutdown, after a bit of time i started the laptop again and this time it booted up to the GRUB screen, i selected the Endless OS option and got stuck again in a black screen with an _ underscore on top. I waited a while, and nothing, so i forced shutdown again, booted up to the GRUB screen again, selected the option advanced and selected the older version of Endless OS (5.0.6) and, even though i don’t know if i should have done this, i deleted the newer version using: “$ sudo ostree admin undeploy 0”, just so i would not need to rollback on every start up, any ideas why the update didn’t apply properly?

Another thing i noticed is that the laptop built-in touch pad is not working, i tried using FN+F7 to no avail, tried just pressing F7 and nothing, also tried pressing Alt+F7 and still nothing, tried removing peripherals and still no response. I then checked the configurations on my laptop for the mouse and touch pad, and there was no options available for the touch pad. Then today i booted up the laptop and entered the BIOS menu, i saw that the clock was set 3-4 hours forward, so i changed it, i also disabled the Fast Boot option, and then i checked the other options to see if there was anything unusual, but all the TPM options were enabled, which i think it must mean the touch pad, but i might be wrong, any ideas on how to fix this?

My laptop is an Acer Nitro AN515-54 and i don’t have dual-boot set-up.

Thank you for the report. I’m sorry 5.1.0 is not working correctly on your computer.

Unfortunately there is no specific information in the diagnostic file about the failure to start 5.1.0. This is probably because the diagnostic file only contains information from the last 2 attempts to boot the system, and you have restarted at least once since the failure to boot 5.1.0.

To help us to solve the problem, please:

  1. Update to 5.1.0 once again
  2. Attempt to boot into 5.1.0
  3. Wait a minute, then restart the computer
  4. Choose 5.0.6 from the GRUB menu
  5. Create another debug log
  6. Attach the log here

A TPM is not related to the touchpad.

I can see from the log you generated that the laptop originally came with Endless OS 3.7. Did the touchpad work when you first got the laptop? Do you happen to remember at what point the touchpad stopped working?

eos-diagnostic-231206_115008_UTC-0300.txt (1,5,MB)

Hello again, sorry for taking so long and thanks for your response, i really appreciate it. Yesterday i turned off my laptop and today, somehow, Endless OS updated automatically to version 5.1.0, even though i have automatic updates disabled and have flagged my WiFi connection as limited, but since i had to test the update anyways, no loss, i just hope this time the debug log is within the 2 boot attempts you mentioned.

About the touch pad, somehow it is working again and as far as i remember, it always worked normally, it started acting strange since 1-2 months ago i guess, but i don’t know what i did to fix it, from yesterday to today all i did was to remove one of the peripherals from one of the USB ports (i think this port is a 2.0 port, because it doesn’t have a blue detail on it, but i could be wrong.)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.