Disk burning applications for Endless OS

The other day I had need to burn an iso image to dvd. My computer has a DVD burner in it that has probably never been used. I went looking in Software but I did not find either Brasero or K3b. What should one use to burn an iso to DVD?

Thank you for your response. I had noticed that PowerIO was listed in flathub. PowerISO is a commercial product and is closed source. I was hoping for k3b or perhaps Brasero and was somewhat surprised neither was available on flathub.

You can try this:

sudo wodim -v -dao speed=4 dev=/dev/sr0 image.iso

Where:

-v (-verbose) – turns on displaying information about the recording process;
-dao – disc recording in Disc-At-Once (DAO) mode, i.e. it will be impossible to write additional data to this disk;
speed=4 – recording speed;
dev=/dev/sr0 – device;
image.iso – used iso image

Thank you for posting the information. I was not even aware one could burn media via the command line. Unfortunately wodim is not included with Endless. I received the error command wodim not found.

Optical media is not used too much now, but my desktop machine does have a DVD burner and perhaps twice a year I find a need to use it. Looks like I will either need to purchase PowerISO or use a different OS when the occasion arises where I need to burn a CD/DVD

Brasero was previously built-in but was removed in 5.1:

You may be able to get Brasero working in a Toolbox container:

I also hold out hope that a community member will submit Brasero to Flathub. You could try cloning this repository and building it:

git clone git@github.com:AppleMayExist/flathub.git AppleMayExist/flathub
cd AppleMayExist/flathub
git switch org.gnome.Brasero
flatpak-builder --install --force-clean --user _build org.gnome.Brasero.yaml

Thanks for your response. I had no luck with the commands. The first command:

Produced an error that I did not have permission. Tried it with sudo and still got the error.

I did some more looking later and it looks like 5 hrs ago a Daniel Foster took up working on a flatpak.

You fellows are pretty good and very responsive. Thank you so much it is much appreciated.

Try installing a test build of the Flathub submission:

flatpak install --user https://dl.flathub.org/build-repo/83863/org.gnome.Brasero.flatpakref

It would be useful to know if it works for you!

That was fast, thanks. Sadly I had no luck. Selecting “burn iso to disk” produces the error that the format for the iso is not recognized. Selecting an iso in Nautilus and using “open with” Brasero results in being immediately being logged out. I tried to create a project to burn some files to a CD and it resulted in a “missing libraries” error.