Don`t work touchpad & Fn keys Lenovo IdeaPad 3 15IIL05

Hi!
On notebook Lenovo IdeaPad 3 15IIL05 Touchpad and Function Keys not working.
Fn F1, F2, F3 - work with pressed ALt+F1(F2, F3), sound On/Off, +, -. Over keys not work.
eos-diagnostic-201017_165746_UTC 0300.txt (836.2 КБ)

Check this post, it might help

Good day.
Thank you for the advice but unfortunately it did not help, there is no fast boot menu in the BIOS settings.
I took a photo of all the BIOS pages, Disabled everything that is possible.
I also forgot to mention that I also tried to update with the “eos-fix-ostree-repo” fix earlier, but after executing the commands, nothing was updated - the update was not required.

Photo

Interestingly, with these settings, the Fn buttons began to work as they should, by pressing and holding Fn.
Unfortunately, turning off and on the touchpad via F6 does not affect the operation, the touchpad still does not work. :frowning:
To reduce the time, I’ll try reinstalling Endless with these settings…

Reinstalling will probably not make any changes. What could help is:

  • Set your Systems boot mode to UEFI (yours is set to legacy). This often fixes many problems. (Boot Priority setting)

If this still does not make it work as expected, wait for 3.9.0 which will be released soon and contains a huge amount of new drivers in the kernel (Kernel 5.8 instead of the current 5.4)

/edit: If you are willing to take the (IMHO little) risk of installing a Beta version of EOS, you could issue the following command:

sudo eos-stage-ostree demo

This will set your system to receive Beta (=Prerelease) versions of the entire OS.

Thank you for your suggestions.
Initially, the system was installed under the UEFI interface (almost with default settings with disabled boot security and operating system optimization), I changed the settings already when trying to solve the issue (after I created the theme).
I had already rearranged Endless OS, was waiting for updates to be installed, and wanted to make a report again and send it.
I ran the command you specified via ALT-F2, and I’m waiting for an update now. However, I don’t see any process running… In the App Center, there is only the number 2 in the Updates tab and there is an Update All button that I tried to click, but visually nothing happens.
Maybe the command should have been run from the terminal? Should I now wait for the ALT-F2 command to be executed if it is executed in the background?

update: Sorry - i see in process monitor CPU1 workload 50-70%…

Generally, run commands in the Terminal as you will see their output. You can watch the progress (log) of the updater with the following command:

journalctl -f -u eos-updater

So do the following:

  1. Open a Terminal and run the above command
  2. Open a second Terminal and run the command sudo eos-stage-ostree demo.
  3. You should now see a log in the first window which indicates the download of the update. The update has been downloaded and applied if you see a line containing “UpdateApplied”

Good day.
Thanks!
He performed all the actions and executed all the commands.
The touchpad didn’t work.
I think as you said it was at UEFI.
I reset the BIOS settings, set the boot only to UEFI, disabled only the Optimized OS option and Secure Boot, reinstall the system. I will also do all the steps for updating to the beta version in order.
Based on the results, I will make logs and inform you.

Hello again :slight_smile:
Installed the system in UEFI mode.
Updated to beta version.
The touchpad and some of the Fn keys never worked.
And if earlier it was possible to make the rest of the Fn keys work by switching settings in the BIOS, now it was not possible. The eos-fix-ostree-repo did not apply.

After the update, the system was not updated immediately, probably 2 or 3 more reboots, the version was shown 3.8.7 (so I made a screen that the version was old).
Attached the update log in a text file. Also 3 diagnostic files (before the update, after the update but with version 3.8.7, and the last control one after all the actions).
I hid screenshots and files in the summary.
In the BIOS, the settings are all by default, everything is included, so to speak … If you need to, I can take a photo.

Log & Screens

log update.txt (20.9 КБ) eos-diagnostic-201020_134550_UTC 0300.txt (1.0 МБ) eos-diagnostic-201020_154854_UTC 0300.txt (945.2 КБ) eos-diagnostic-201020_161427_UTC 0300.txt (1014.2 КБ)

Sorry, but the laptop is not mine and I have to give it back today.
Best regards!