Endless doesn’t boot up

Please help!! Notebook Acer 5 doesn’t boot up. How to get the eos-diagnostic log file?

Please attach the eos-diagnostic log file for any Endless OS problems, and a screenshot or camera image of the error message itself.

To generate an eos-diagnostic file:

  1. Open the application called ‘Terminal’. You can search for it by typing into the search bar on the desktop.
  2. In the Terminal, type the command: eos-diagnostics
  3. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze it and seek a possible solution


Sorry to see that you are having trouble. In that second photograph, you are at a menu. You should be able to follow the instructions on https://support.endlessos.org/en/troubleshooting/boot-previous-version to select the previous version of the OS.

After you have done this and successfully booted the previous version, please create a debug log following these instructions:

and attach the debug log here. This will help us to diagnose the problem. Thank you for your support

1 Like

@wjt I have the same problem!
eos-diagnostic-231205_121539_UTC-0300.txt (1,1,MB)

Thank you!

OK, assuming you tried to boot 5.1.0 just before generating that file, we are a bit out of luck: there is nothing in the journal from the attempt to boot 5.1.0, which means the boot is failing really early.

In the GRUB menu, highlight the 5.1.0 option and press e to edit the boot commands. You will see something like this:

Screenshot from 2023-12-05 15-35-57

Please take a photo. Then use the arrow keys and delete key to remove the words splash and quiet from the linux line:

Screenshot from 2023-12-05 15-36-23

Now press F10 to boot. With luck we will see more information about the failure…

Thank you! I successfully boot up with the old version. I hope this will be fixed soon in the new version. Anyway, I didn’t have any trouble for the last 2 years! I love Endless and the support that you guys give us all.

eos-diagnostic-231205_174741_UTC-0300.txt (1,3,MB)

From the logs in this discussion thread, I notice the models have NVIDIA card 1650.

@LeandroStanger can you please follow the same steps in steps in @wjt’s comment Endless doesn’t boot up and add the following parameter at the end of the line that begins with linux:


That will disable the NVIDIA driver in the boot.

Hope this help us understand relating to the NVIDIA device, or not.

@starnight Still the same thing!

1 Like

@LeandroStanger Can you try once more, removing splash and quiet and adding the following:

earlycon=efifb loglevel=7

@wjt Still the same thing!

Once more, with splash and quiet deleted and the following added (=, is not a typo);

loglevel=7 earlyprintk=,keep earlycon=efifb


@wjt Still the same thing!

@LeandroStanger Please ensure all data you value on your computer is backed up on another disk before reading the rest of this message. There is a (small) chance that these steps might cause data loss.

Once you have checked your backups, try going into the BIOS settings and looking for settings that control “Intel RST”, “Intel Rapid Storage Technology”, or similar. If you find such a setting, please take a photo before you make any changes, and if there is an option to switch to AHCI mode, please try changing that (take a photo of the change) and see if 5.1.0 boots. If it succeeds, let us know. If not, please also let us know (and change back whatever settings you changed).

(We believe the error is related to a custom driver in Endless OS to support this RST mode; but unfortunately our team does not have any devices which require that driver for testing. We are trying to locate one!)

@wjt I can’t find this option!

@LeandroStanger Perhaps you can share some photos of the BIOS settings, maybe it’s there under another name.

Another thing to try is to boot 5.1.0 with splash and quiet deleted and the following added:

    modprobe.blacklist=intel-nvme-remap loglevel=7

This is not expected to make the system boot but if it is the intel-nvme-remap driver that is crashing, you may get a different error message to help validate that theory.

@wjt Still the same thing!

Are there any other options under the “Main” and “Boot” tabs in the BIOS?

Having consulted with the original author of the driver we suspect to be at fault, please try the following. Boot 5.1.0 with splash and quiet deleted and the following added:

    loglevel=7 initcall_blacklist=nvme_remap_drv_init 

Again, this is not expected to make the boot process succeed but if we get a different error it will confirm our theory.

Sorry for not being of help, I don’t feel secure following the instructions because I have little know-how. I fear ruining the system even more or losing my data. There is no more room in the external HD.