Upgrade 5.0.6 to 5.1.0 failed, ASUS frozen at Bios

La mise à jour de 5.0.6 vers 5.1.0 ne s’est pas bien passée.
Le PC freeze sur l’écran du BIOS d’ASUS.
La nouvelle version 5.1.0 sur OSTREE 0 ne démarre pas !
Je suis obligé de passer par le GRUB et démarrer la version 5.0.6 sur OSTREE 1

Antécédent : il y a un mois, j’avais eu le problème au démarrage répertorié error: no such device: ostree, qui avait été résolu par le démarrage via la clé USB de la version 5.0.6 et un simple redémarrage.

Comment ne plus avoir à démarrer par le GRUB ? Quite à rester sur 5.0.6 ! Merci !

Hi there,

Sorry this update is not working on your device. Please can you perform the following steps to help us to understand the problem:

  1. Attempt to boot into 5.1.0.
  2. Wait a minute, then restart the computer
  3. Choose 5.0.6 from the GRUB menu
  4. Create a debug log by following these instructions
  5. Attach the log here

The log will, if we are lucky, include information from the failed boot into 5.1.0, which may help us to diagnose and fix the problem. Thank you in advance for your assistance.

I have the exact same issue.eos-diagnostic-231205_184415_UTC 0100.txt (1,0 Mo)

Can you find something in it ?

Hi, thank you for your help.
Here it is (eos-diagnostic-deleted)

:wave: Hello ? Is it possible to have some feedback from the log ? Do I need to change my laptop ?
Best regards.

Forgive me for not replying – I thought I had done so!

Unfortunately when this problem occurs there is no information in the log file about the failure to start up. On this other thread, we are trying to diagnose the problem. We believe it is related to the storage configuration on these devices.

There are two things you could try to help us understand the problem.

One is to go into the BIOS settings and look for an option named something like “Intel RST”, “Storage Configuration”, or “SATA/NVMe Operation” which is set to “RAID mode”, and change it to “AHCI” or “NVMe” if that is an option. Please take a photograph of the BIOS settings page before and after you make this change.

It could be that this will allow you to boot into 5.1.0. If it does, let us know and share the photographs! If it does not, please also let us know, and change the setting back.

The other thing you could try to get more debug information is to follow these steps:

Sorry for the difficulties here. We’re in the process of purchasing an affected laptop so that we can investigate the issue and resolve it in another software update ASAP.

Ok. You’ve got to be kidding me, cause I took a lot of screenshots, but “new users can post one picture only”… What the hell…

(edit: picture deleted)

So, here I have only one choice and can’t pick up anything else.

Then I tried to delete Splash and Quiet…

(edit: picture deleted)

And that’s all I got…

So, I tried to take screenshots of the 5.0.6 starting log… but it’s too fast, one second or so… So I took a video where many errors are readable but… Seriously, again ? We can’t uploard videos, here…

Finally I screenshoted the video screenshot… I don’t know if it has any value for you, yet, here we go… Sorry for the flood.

(edit: picture deleted)

(edit: picture deleted)

(edit: picture deleted)

(edit: picture deleted)

(edit: picture deleted)

And there, 5.0.6 connection log screen comes in…

(edit: picture deleted)

Now I keep it in standby mode, instead of turning it off. With hope this problem could be fixed sooner than later.

IMPORTANT : if anything in those screenshots can be a security problem for my laptop, please remove them from the public forum ASAP. Thank you.

Thank you for your help.

Sorry for the hassle with the forum posts there. I upgraded your trust level in case you need to post multiple images again. And there’s nothing sensitive in the images you posted.

We have an affected laptop model on order which we should receive next week, hopefully we can resolve this quickly from that point. Booting the previous version 5.0.6 is our recommendation while we work on the issue.

If you would like to help further though: I believe if you explore more around the “Advanced” menu of your BIOS setup screen you will find some kind of relevant option, any one of the following:

  1. “Intel RST” / “Intel Rapid Storage Technology” / “Optane” - if you find any option here, mark it as Off or Disabled
  2. “SATA Configuration” / “SATA Mode Selection” - if this is set to “RST” or “RAID”, it should be set to “AHCI”

If you are able to find and modify either of those options as indicated, it’s highly likely that Endless OS 5.1.0 will boot fine. (would very much appreciate your confirmation if you try it!)
Here is a video of this configuration item for a different Asus product : https://www.youtube.com/watch?v=_M_yOwBoCA8

No pressure to try this though - I understand this whole ordeal must be rather frustrating and if you’d prefer just to sit tight on 5.0.6 while we figure this out, that’s perfectly understandable!

Thanks again, unfortunately, I have no option available in Intel RST / Optane.

However, I’m happy to confirm that

is the solution. Now it starts flawlessly with 5.1.0
Problem solved. Thank you all !

Many thanks for the confirmation!

It worked ! thank you !!