Endless on 2008 MacBook Pro

I recently picked up a very nice 17" 2008 Macbook Pro. It is a very nice looking machine, with a beautiful screen and working battery and I think it would make a wonderful Endless laptop. However I can not get it to boot the Endless installer.

It has Nvidia graphics a core2duo processor and 4GB of RAM. When I boot with an installer USB stick and select to boot from efi, the laptop mostly just hangs and on a couple tries, it actually shuts down.

This is not that important of issue, but I would like to solve it. I do not know what video drivers your installer includes. I do know that old Nvidia cards generally cannot boot from efi, but it is my understanding that the Nouveau will boot from efi.

If anyone has experience with this machine or similar hardware I would appreciate any pointers.


Can you try to blacklist the nvidia proprietary driver by holding down shift when booting the Installer and append the following kernel parameter:


Does that allow the system to boot?

Thanks for the pointer, but unfortunately it does not help.

It does not even get to that point. Starting the MBP with the Option Key held down, gives me the choice to boot into the MacOS or to. boot from efi on the thumb drive. When I select the efi the system 5 times out of 6 just freezes and 1 time out of 6 the machine just shuts down.

As i don’t have a Macbook i can only base my assumptions on some google research i’ve done:

  1. Some early Macs seem to have, despite the 64 Bit compatible CPU, a 32 Bit EFI implementation. If this is the case in yours, you’re out of luck booting a recent Linux with EFI. The last first generation Macbook suffers from this, it was released in early 2008. The second one does not and was also introduced in late 2008, so please check this.

  2. There must be an option to perform a legacy boot which instead of using EFI to boot, uses the classic BIOS boot procedure. Please check that too.

  3. Have you tried to boot into OSX successfully? Some first generation Macbooks seem to have a well known issue with their GPU (heatsink looses it’s connection to the die) which produces behavior similiar to the ones you described in your first post.

Thanks for your pointers.

This MBP is 64Bit EFI compatible. It boots OS X fine, and it boots many Linux versions as well, but there are some that it chokes on. Mac embraced Intel’s EFI and I think all Macs released after 1999 only provide for EFI booting. Intel opened up EFI and it is now called UEFI, but Apple never switched to UEFI and still follows the old Intel EFI standard. Macs need to have a properly formatted and populated EFI partition as well a “/EFI” folder will not work.

I pick up old machines that interest me and fix them up. I finally got a DVD burner for this machine a couple weeks back. Typically after I get them working, I will pass them on to after school programs or senior centers. Both of which are excellent environments for Endless OS. Also on donated machines Endless is robust enough that very little support is required. So while the 17" MBP is ideal hardware for senior center residents, I would not feel comfortable passing it on if recovery or repair required lots of tinkering.

Endless OS bundles the proprietary NVidia driver. Years ago I successfully booted an Endless OS ISO on a ~2008–2009 Mac Mini (using EFI) but never tried to get any further.

Thanks for the information. The 2008 MBP seems to boot from Linux Distros, that do not use the proprietary drivers. I think the Nvidia card is just too old to play nicely with newer Nvidia drivers. Fedora boots, Debian boots. It is noted with some irony that one of the most closed proprietary machines, seems to prefer open source drivers. :slight_smile:

Can you please boot with:


I accidently used a dot in my first answer, which is wrong … :woozy_face:

Sorry to keep coming back to this. How does one start Endless to get an option to edit any of the boot parameters? I have not been able to arrive at a point where I could enter “module_blacklist=nvidia”

thanks for your attention.

When you are at the boot menu (hold down shift or ESC before the operating system boots), you can edit the entries with the ‘e’ key. There’s a entry starting with ‘linux’, append the module_blacklist there.

If that works and you can boot that way, the next step is to make this fix permanent after installing Endless OS. To do so, boot the installed OS with the same procedure as above, then open a Terminal and run:

echo blacklist nvidia | sudo tee -a /etc/modprobe.d/blacklist.conf

This will force the use of the nouveau driver subsequently.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.