Endless OS 3.7.8~beta2 Won't update Raspberry Pi 4

When I run eos-updater-ctl update I get an error message GDBus.Error:com.endlessm.Updater.Error.WrongState: Can’t call Fetch() while in state Ready (36)

I’ve tried various fixes found in the forums such as eos-updater-ctl poll
I’m new to the Endless Community and would like to be more involved.

1 Like

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:


  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

Leandro Here is the info you requested I also added a file showing the full error message I got when running eos-updater-ctl update. Thought that might help too. I like the eos-diagnostic feature.

eos-diagnostic-200303_214503_UTC-0700.txt (286.5 KB) UpdateError.txt (1.2 KB)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.