EndlessOS 5.1 dosen't boot up on raspberry Pi 4


The Endless OS is not starting and stop after the message “starting Kernel”, I update the bootloader to teh last version , test the lite and full version , but i still have the same behaviour
Could you please help on this
Thank you

IMG_2566 Medium


Thanks for the bug report. This issue has been identified.
The kernel image size is too big to fit in the memory space now.

It will be fixed in future version.

Hi Thank you for your answer,
do you know if any old version may works ? and how to download it

Sorry! I did not notice it is EOS 5.1. EOS 5.1 should boot finely. At least, it boots on the RPi 4B (4GB) on my hands. It is supplied by a 30W power adapter.

The big kernel image issue only happens in the newer & developing Endless OS version.

We can try to understand what happens after “Starting kernel …” by having logs.

I believe that you download the Endless OS Raspberry Pi image from Endless OS for ARM. Then, flash the image into a microSD card, or an USB stick.

If you insert the microSD card, or USB stick into your workstation, you will see there are two partitions: boot (usually labelled as a hex string) & ostree partition, and they are mounted as:

$ ls /run/media/<username>/
4E56-10F9  ostree

You can edit the ostree/boot/uEnv.txt's bootargs by dropping “splash plymouth.ignore-serial-consoles quiet” and setting loglevel=6, like

$ cat /run/media/<username>/ostree/boot/uEnv.txt 
#bootargs=rw splash plymouth.ignore-serial-consoles quiet loglevel=0 ostree=/ostree/boot.1/eos/7d8403178d07b41ad71f1156e796b09dfafe693731a2ddc084069fa64037dd71/0
bootargs=rw loglevel=6 ostree=/ostree/boot.1/eos/7d8403178d07b41ad71f1156e796b09dfafe693731a2ddc084069fa64037dd71/0

Note: You need the root privilege to edit uEnv.txt.

Then, insert the microSD card, or USB stick into Raspberry Pi 4B and boot again. You can see the logs after “Starting kernel …”. I believe

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.