EOS 3.8.5 RPi4 8GB Wired Mouse and keyboard not detected

Hello,
I’m trying EOS 3.8.5 in my Raspberry Pi 4 8GB.
But as soon as it comes to the first screen (language choice) mouse ad keyboard are not detected: nothing happens, no matter with USB port I’m plugging in.
Did anybody had the same problem?

Thanks

PS: I hope the topic is posted in a proper way

Hi, please send us a diagnostic.

Hello,
Thanks for your reply: do you mean I should press ALT F2 during boot?

The problem I have is with the first of the configuration screens (when EOS asks for language choice).
No key or mouse movement is detected no matter which USB port I am plugging in to.
I’m sure they work because with another SD (with Raspbian OS) I’m able to work.
Thanks

Hello @iWally one thing you could check will be the adapter, there is a slight chance the USB keyboard/mouse won’t work if they can’t draw enough power from the board.

Please reference the power supply spec. from RPi official page, and see if your adapter had similar output number: https://www.raspberrypi.org/products/type-c-power-supply/

Hello Yung
I tried also brand new EndlessOS 3.8.6: same result.

With Ubuntu Mate, Raspbian and Twister USB mouse and keyboard are working with no problem.
This leads me to think the issue is on OS side. Don’t you agree?
Thanks

Hey iWally yeah, it seems there is a firmware difference between 4GB and 8GB model.
Also, the EOS image does use the mainline kernel, which is different compare to Raspbian.
But I don’t currently have RPi 4 8GB in hand, I will ask around and see if I can find the hardware to replicate your problem.

I can confirm that my Logitech wireless mouse and keyboard not detected on Raspi 4 8 GB with Endless 3.8.6. It stuck in the welcome screen (language select). On the other hand, on other images (i.e., openSUSE and Manjaro) works well.