Eos-Apps or Flathub

Can anyone tell me if the eos-apps repository is currently live? Or an application, for example Google Chrome, can only be updated from Flathub.

Endless OS is designed to use flatpak applications. As far as I know they use the main flattub repository for most applications as well as having a flatpak repository for applications that are specific to Endless.

There are ways to layer in other applications. Information for that can be unearthed at https://support.endlessos.org/en/dev

I had a problem with Google Chrome and wanted to update it. Chrome was originally installed from the eos-apps repository. But now, for reasons unknown to me, this repository is unavailable. So I was wondering: is it possible to update Chrome from the Flathub repository, where it is also located?
However, this is no longer important. I tried this and the result was fatal - the system froze during the update process and I had to abort the update.
Now I can’t install any app from Flathub.
I’ll probably have to deal with reinstalling Endless OS.

It’s quiet here. :slight_smile:

I installed Google Chrome from EOS Apps just 2 or 3 days ago. Is is still unavailable for you?

Everything is the same as before - no access.

Share your advice - how to roll back Libre Office from version to version Unfortunately, I couldn’t find on Flathub. Where else can you look?

It became very quiet here. And this probably saddens many ordinary users. Did the EOS team just disappear? What happened to these guys? I hope everything is fine with them.

I haven’t been here for about 2 years. Why? Yes, because everything was fine with me. The laptop is working fine, EOS 3.5.8 installed on my old laptop is stable. And it was quite suitable for my modest needs. What else does a person need at the end of his life’s journey?

All the troubles began after the online translator in Google Chrome stopped working when opening websites. I found information from Google that translation will not work in Chrome 95 and older. I had version 89 installed. In the EOS repository now for installation - version 92. On flathub - version 118. Conclusion: you need to install from flathub! I’m right? I think I’m right.

But here is a new ambush. The data transfer speed on flathub is very low - a maximum of about 400 kbit/sec (when downloading torrents the speed is 4-5 mbit/sec). I didn’t even try to install Chrome, but I installed Libre Office. It was an unforgettable sight. If earlier the office was installed in 2 minutes, now it takes 20. Plus another 25 minutes to downgrade the version. I wanted to downgrade to version I think this was the most stable version in my practice. There is no such thing on flathub anymore - the oldest is, but the simplicity in the appearance of the application has already disappeared. It’s a pity. I’m afraid that my laptop will no longer be able to work with this office.

Sorry for leaving you hanging. The chrome version on eos-apps works fine. I’m using it right now. However, the version in flathub should work fine, too. Eventually we’re going to migrate users from the eos-apps version to the flathub version, but it’s a little involved.

Are you still having trouble updating the version from eos-apps? We had a stupid issue that was preventing the updates from being published. Currently it’s at 119.0.6045.123-1 and 119.0.6045.159-1 should be published shortly.

Thanks for the help.
I was able to regain access to Eos-apps and install Chrome. But Chrome doesn’t want to start. That is, the window opens (shows something like an hourglass) and closes.

Currently working in Chromium which is installed on my EOS 3.5.8 system.

  1. Expired security key.
    Thank you. I tried importing a new GPG key and the result: 0 keys imported.

  2. Google Chrome.
    As I reported earlier - I was able to install Chrome from Eos-Apps, but the app won’t launch. I tried to install Chrome from Flathub: as it turned out, Flatpak with version 1.8+ is required. I have EOS 3.5.8 on my laptop and, accordingly, Flatpak with version 1.0
    But I was able to install Libre Wolf - I’ll try it.

  3. Libre Office Calc.
    And finally, a question for the experts. I installed Libre Office and noticed a strange bug. When editing, the cursor in the formula entry line does not blink, although it blinks in the cell as expected. I tried to reinstall - it didn’t help. This bug is present in all latest versions of Libre Office. As I understand it, if the problem was with the video adapter, the cursor would not blink in the cell either. How to treat?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.