Epson L380 scanner not working


#1

Installed 3.6.2. Printer L380 installed propely but scanner not working. Is there any way to make the scanner working.


#2

Solved the problem [Thanks to google-(https://forums.fedoraforum.org/showthread.php?297277-xsane-can-access-USB-scanner-only-as-root)]. First tried to add user to group ‘lp’ via adduser command in the terminal… However, it returned error that group ‘lp’ does not exist in /etc/group file. So I looked for the scanner id by using ‘lsusb’ command. Then found the device id file in '/dev/usb/00*" Changed the group of the device id file to the group ‘lpadmin’ which was mentioned in /etc/group file, logged out and logged in and the scanner started working.


#3

Glad you could find a workaround! Could you connect the scanner, run eos-diagnostics, and attach the file here? What were the permissions on the device file before you changed them? (The output of ls -l /dev/usb while the scanner is attached would be great.)


#4

As advised -

  1. The eos-diagnostic file is attached.
    eos-diagnostic-190820_235141_UTC 0530.txt (600.5 KB)
  2. The output of ls -l /dev/usb -
    $ ls -l /dev/usb
    total 0
    crw-rw---- 1 root lp 180, 0 Aug 20 23:51 lp0

closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.