Epson WF-2530 no longer prints


#1

Hi everyone,
I have an Epson WF-2530 installed on Endless 3.5.3 which has been working fine. A week or so ago the printer stopped printing so I deleted it, reinstalled it and it worked again.
Unfortunately it has stopped working again. I have deleted/reinstalled it a few times but to no avail. The printer is recognised, and I can see the ink levels, but it won’t print. If I try to print a test page, Endless says printing, the power light on the printer flashes briefly and "printing… " appears on the lcd screen of the printer for a second or so, but nothing prints and the printer goes back to normal. Endless flashes up a message to say the printing has been completed.
Any idea how to fix this?
TIA
eos-diagnostic-181231_101601_UTC 0100.txt (2.6 MB)


#2

@wjt @ramcq Could help?


#4

I can confirm that It is not a printer problem as the printer works perfectly with a Windows 7 computer on the same network.


#5

Anyone? It’s getting to be a real pain not being able to print!


#6

@mario @wjt @ramcq Could help?


#7

I briefly checked the logs and I don’t see anything standing out in particular: communication with the printer seems fine, data to be printed seems to be read and sent and no errors are showing up while printer, not even by the filters used by CUPS.

It could be a communication problem with the printer, though. Have you tried connecting over USB and printing that way?(that is, configuring it as a local USB printer instead of using it from the network)


#8

Thanks for your reply Mario.

I haven’t configured it as a USB printer because it is used by other computers over the network. I have just connected another laptop running Endless 3.5.3 to it over the network this morning and that prints fine.
Is there a way to manually delete the driver, so when I re-install the printer it will re-download the correct driver?


#9

Oh, right! It’s one of those printers that download drivers from openprinting.org automatically (see http://www.openprinting.org/printer/Epson/Epson-WF-2530_Series). It’s quite weird though that you got the driver to a corrupted state, but I undertand you want to manually delete the driver and try again, so here is what I would do:

Unfortunately, there’s no automated way and this implies using the terminal as root, so please be careful and understand what you’re doing. Here we go:

It’s basically two simple steps, both performed from the terminal (it will ask you for a password when typing those commands):

  1. Remove the symlink that makes the printing subsystem find the installed driver:
  $ sudo unlink /var/lib/eos-config-printer/ppd/epson-inkjet-printer-201211w_ppds_Epson
  1. Remove the driver from the installed location:
  $ sudo rm -rf /opt/epson-inkjet-printer-201211w

(Note that the name of your driver could be different than epson-inkjet-printer-201211w, although checking in openprinting I feel fairly confident that it will be that name)

Once you do that, trying to re-install the printer again (after having removed it first, of course), should trigger the same process that made you download the driver the first time and, if things work as expected, your printer should work as nicely as in your other laptop.

Good luck!
Mario


closed #10