Experience and problems I found when trying Endless

I have been using Endless for a few days, firstly from a live usb and then from the installed version alongside Windows 10, and I wanted to share what I think is good and what needs to be solved.

First of all, one of the things I like the most about this OS is the aesthetic appearance of the entire experience. From the boot moment, I was astonished by the polished details and the clean appearance of the desktop and the apps. The inclusion of educative apps and interesting links in the Chromium browser has been a perfect decision, since it has let me get to know fantastic sites and apps I didn’t know before. Also, the simplicity of this OS makes it extremely easy and intuitive to work with it and get the work done without distractions.

However, even though I had a good impression when testing the touchscreen response (it even seemed to work better than Ubuntu), I have found some problems that can ruin the entire touch-only experience. For instance, I found that it was impossible to open a folder when pressing it with my finger through the touchscreen, and when I tried to scroll down the content of the upper panel that appears in the desktop, the panel suddenly closed and a secondary menu (the one that pops up when long-pressing the background with the finger, or when left-clicking) appeared, even if I had not touched the background at all.

In addition to this, I have to say that the fact that the secondary menu appears when long-pressing the screen with the finger is fantastic, since it does not even work in Ubuntu. However, it does not appear when trying to press folders or other elements.

Furthermore, I had problems when pressing the power button to lock the PC. It suspended the computer correctly, but when I pressed the button again to turn on the PC again, the screen turned on and off in a sudden, leaving me without the possibility of unlocking the screen; no matter how many times I tried to press the power button. Therefore, the only way of unlocking it was by pressing any key of the keyboard, which I was trying to avoid.

It is important to know that my computer is an Asus Transformer Book T101HA, which is a convertible with detachable keyboard and touchscreen.
Processor: Intel® Atom™ x5-Z8350 CPU @ 1.44GHz
Memory: 128GB SSD
Screen: 10.1" 1280 x 800 (resolution)

Despite of this problems, I think that the overall experience has been more than satisfying, so I congratulate the Endless team for this fantastic job and encourage you to keep developing this incredible project.

@sapemi What version of Endless OS are you using?
(To check which version of Endless OS you are in Settings :arrow_right: Details)

I just downloaded the last basic version, obtained through the endless-installer: 3.4.8 (181012-212653)

Update Endless OS for the latest Endless OS 3.5 release to download the update for Endless OS 3.5 just go to App center

Could you tell me the approximate size of the download? I have a restricted connexion of Internet now.

Thanks for the feedback! We’re aware that the touch-only experience is lacking in some ways. It’s not a priority to improve this at the moment, but we hope to work on this in future, and we’ll continue bringing in the latest improvements from the GNOME/Ubuntu communities.

Along those lines, the latest version of Nautilus (the file manager) solves the touch issue you describe; this will be available in Endless soon. I have also reported your touch issue with the discovery feed for checking internally.

Your hardware is based on Intel Cherry Trail; unfortunately Intel did not do a great job of Linux support for this chipset (it was more aimed at tablets), which probably explains the suspend/resume screen issue you are seeing. There is indeed a new version of Endless available, we have not specifically worked on the issues you mentioned so I think the chances of them being fixed by this update is low. Regardless it is probably worth upgrading and checking anyway when your bandwidth permits.

The OS update from EOS-3.4.8 to EOS-3.5.0 is approximately 230mb download size.