Flatpak complains: "F: Ignoring duplicate content rating" - how to get rid of this

Since quite some time, I get several lines of
F: Ignoring duplicate content rating
before any reasonable output, when I run flatpak commands, like list or update. I am not sure if that does any harm, but it is a bit annoying.

What does it mean and how do I get rid of it?

eos-diagnostic-221125_151900_UTC 0100.txt (1.1 MB)

PS: there are 732 occurrences of “Ignoring duplicate content rating” in the eos-diagnostic included above

hmm, very silent here. Is there somebody who can give me some hints how I could proceed/debug the situation?

@pwithnall any quick ideas here?

The warning happens because the metainfo (formerly known as appdata) for one of the apps in one of the flatpak remotes you have configured erroneously has two <content_rating> elements.

The fix will have to be applied to the app which has the erroneous data, so the problem is with one of the flatpak remotes you have configured, and it will be affecting every user of that remote.

You could try and find the problematic remote/app by running the following command in a terminal:

appstreamcli validate --no-net {/var/lib/flatpak,~/.local/share/flatpak}/appstream/*/*/active/appstream.xml | grep tag-duplicated

Hi Philip,

thanks for

but sorrily these command(s) do not reveal anything:

BTW, I am not sure if it is only a warning since there is a F: prepended to the message text.

Where did you install R Studio from? I’m wondering if that’s causing the errors

Oops, you may have spotted the reason.

See What about R in endless for more info how I installed RStudio 4 years ago. I find it frustrating that there is absolutely no progress for a RStudio flatpak.

@pwithnall uninstalling RStudio does not remove the F: Ignoring duplicate content rating messages. It removed several other packages:

$ flatpak uninstall RStudio
Found installed ref ‘app/com.rstudio.RStudio/x86_64/master’ (system). Is this correct? [Y/n]:

    ID                                                      Branch           Op
  1. [-] com.rstudio.RStudio master r
  2. [-] org.kde.PlatformTheme.QGnomePlatform.Sources 5.11 r
  3. [-] org.kde.PlatformTheme.QGnomePlatform 5.11 r
  4. [-] org.kde.Sdk.Locale 5.11 r
  5. [-] org.kde.Sdk 5.11 r

Uninstall complete.

but the following still remains:

$ flatpak list | grep -i RStudio
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating
F: Ignoring duplicate content rating

In the meantime I did a sudo flatpak repair without success. Trying to find out, what is causing these errors, I grep'ed the eos-diagnostic files for “Ignoring duplicate content rating” and learned that these messages started to occur in January 2020. Trying to find out, what I installed back then, I tried flatpak history but this fails miserably saying: error: appstream2/x86_64 is not application or runtime (both as normal user and with sudo).
@pwithnall do you have any further ideas/suggestions?

It’s our own apps from eos-apps. See /var/lib/flatpak/appstream/eos-apps/x86_64/active/appstream.xml. For example:

<component type="desktop">
    <summary>Aprende acerca de las criaturas de la Tierra</summary>
    <description><p>Los animales son increíbles. Desde el majestuoso león hasta el extraño y fascinante ornitorrinco, hay mucho que aprender sobre las criaturas que habitan nuestro mundo. Conoce todo el reino animal con este programa. A toda la familia le encantará aprender sobre las características, hábitos y ambientes de los animales, tanto a pequeños como grandes. Es especialmente importante estudiar el reino animal ahora que tantas especies están en peligro de extinción.</p></description>
    <icon height="64" width="64" type="cached">64x64/com.endlessm.animals.es_GT.png</icon>
    <url type="homepage">https://endlessos.com</url>
    <content_rating type="oars-1.1"/>
    <content_rating type="oars-1.1"/>
      <lang percentage="100">es</lang>
      <value key="GnomeSoftware::popular-background">https://com-endless--cloud-soma-prod--shared-portal.s3.amazonaws.com/app.924.appCenterThumbnail.d44d51e5-a50e-448e-a603-c0524b29d295_201810151913342424.jpg</value>
    <bundle type="flatpak" runtime="com.endlessm.apps.Platform/x86_64/5" sdk="com.endlessm.apps.Sdk/x86_64/5">app/com.endlessm.animals.es_GT/x86_64/eos3</bundle>

There’s nothing you can do client-side to fix this. We’re not currently updating these apps because we are gradually migrating to using Kolibri to distribute offline learning materials, so we’re not in a position to fix this right now either. Sorry.

@wjt thanks for the explanation, sorry to read this, but I can live with the messages …

Just curious: is it the cause for both errors, occurring with flatpak subcommands list and history?

It’s the cause for the F: Ignoring duplicate content rating errors.

The problem with flatpak history is a separate bug in flatpak, which has been fixed upstream but that fix hasn’t made it into Endless OS yet. This should be fixed next time we update flatpak.

@pwithnall thanks, I’ll be patient.

And: Thanks a lot for EndlessOS :+1:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.