Framework update issue 3.7.3


#1

Please attach the EndlessInstaller log file for any install- and uninstall-related problems.eos-diagnostic-191111_185237_UTC 0100.txt (1.3 MB)


#2

Hello, i can’t update my framework on my asus. I tried to do it in terminal( flatpak uptdate command) and there were some errors. So i uploaded diagnostic too. Could you please help me?


#3

eos-diagnostic-191112_140605_UTC 0100.txt (1.0 MB)


#4

Can you please paste the used command and it’s output here in this thread.


#5

shahin@endless:~$ flatpak update
Looking for updates…
Info: org.gnome.Platform is end-of-life, with reason: GNOME 3.24 runtime is no longer supported as of 11th January 2019. Please ask your application developer to migrate to a supported platform.
Info: org.gnome.Platform.Locale is end-of-life, with reason: GNOME 3.24 runtime is no longer supported as of 11th January 2019. Please ask your application developer to migrate to a supported platform.
Error: Error pulling from repo: While pulling runtime/com.endlessm.Platform/x86_64/eos3.1 from remote eos-runtimes: Writing content object: Corrupted file object; checksum expected=‘6f1663ab3da5ddb3f49b74de1cd3101d682e3ef8bb7dd8306e4ff85fa75373fe’ actual=‘898db0fb03b00551d3f55b60dcb2fa6b8119a3612bb07cc1453fdaa80af1af6a’
Error: Error pulling from repo: While pulling app/org.megaglest.MegaGlest/x86_64/stable from remote flathub: Writing content object: Corrupted file object; checksum expected=‘318941638cecae85b277011efa7c0945341e87e8f829384f59dc1dd7dad37eef’ actual=‘513ff498d575707f68e022df214cc09509de664e09a640dd276f8e0fe2713fe1’
Updates complete.
error: There were one or more errors
shahin@endless:~$


#6

can you please try:

flatpak update --appstream --assumeyes
flatpak update --assumeyes

#7

it is still the same error


#8

i updated my os to 3.7.4 beta 2 too but nothing is changed


#9

Error: Error pulling from repo: While pulling runtime/com.endlessm.Platform/x86_64/eos3.1 from remote eos-runtimes: Writing content object: Corrupted file object; checksum expected=‘6f1663ab3da5ddb3f49b74de1cd3101d682e3ef8bb7dd8306e4ff85fa75373fe’ actual=‘898db0fb03b00551d3f55b60dcb2fa6b8119a3612bb07cc1453fdaa80af1af6a’
Error: Error pulling from repo: While pulling app/org.megaglest.MegaGlest/x86_64/stable from remote flathub: Writing content object: Corrupted file object; checksum expected=‘318941638cecae85b277011efa7c0945341e87e8f829384f59dc1dd7dad37eef’ actual=‘513ff498d575707f68e022df214cc09509de664e09a640dd276f8e0fe2713fe1’
Updates complete.
error: There were one or more errors
shahin@endless:~$


#10

You probably don’t need this legacy runtime any more. Try running this command:

flatpak uninstall runtime/com.endlessm.Platform/x86_64/eos3.1

It will give an error if it’s actually being used by some applications – if so, let us know which apps and we’ll try to go from there.

This is an error in this application package. I have opened this bug report and submitted a fix.