Frost Torrent and VLC Media Player not working

After updating the Endless OS, the Frost Torrent app is not launching. The vlc media player is launching but its not playing any videos. It throws some errors while tried to play with it.

Anyway, something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command: eos-diagnostics
  3. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

eos-diagnostic-170210_071127_UTC 0530.txt (312.0 KB)

I have attached the file herewith.

Hi @Vinodh, unfortunately this only includes information since you last booted into Endless OS so it doesn’t tell us anything. Please do the following:

  • Start Endless OS
  • Try to run Frost Torrent
  • Launch VLC, try to play some videos
  • Now run eos-diagnostics again and attach the result.


I think it is not necessary to open a new topic, as the failure of the program is the same.
I have the same problem
Frost Torrent and Translate

eos-diagnostic-170210_213451_UTC 0200.txt (3,7 МБ)

Frost Torrent - does not start !

Translate - It does not translate words !

The problem with Frost Torrent not too urgent, priority is given to programs Translate

Frost Torrent i replaced qBittorrent


Hi @wjt, I have uploaded the eos-diagnostics file again after running Frost Torrent and the VLC media player. Now I can play the videos which are in my internal HDD using vlc but if I try playing videos from my external HDD, vlc crashes. eos-diagnostic-170211_081458_UTC 0530.txt (1.1 MB)
Please find the attachment.

Hi @avkP3, can you please let me know how to install qBittorrent?

Thank you for these reports. I am able to reproduce the problems with both Frost Torrent and Translate. Apparently something is not right in how we have converted these applications to the flatpak format. We will investigate and hope to have an update to these applications soon.

Thank you also for the diagnostic log that shows the error message when VLC is failing when trying to access files on an external HDD. That is really helpful. I suspect it might be a matter of how permissions are set up in the flatpak application. We’ll investigate that, too.


Also, I cannot make the vlc media player the default player, as it is not shown in the list of installed application, when right clicking on any video.

Hi Vinodh.

##Program installation: - qBittorrent.Appimage

Download files: [qBittorrent-3.3.7.glibc2.15-x86_64.AppImage]

##There are two ways to install the program:

The first way - Running without installing the system
The second way - Starting with the installation of the system

The first way - You can run the application from any folder home

The second way - Starting with the installation of the system

Create a start button:

qBittorrent-3.3.7.txt (328 Байт) - download and rename in qBittorrent-3.3.7.desktop

[Desktop Entry]
Exec=/opt/.ИСХОДНИКИ/Исходники/qBittorrent-3.3.7 %u

You have to write your way to run the file (STARTUP-FILES)

=> Exec=/opt/.ИСХОДНИКИ/Исходники/qBittorrent-3.3.7 %u <=

##Allow executing file as program

##Create a folder in the /opt

user@endless:~$ sudo su
[sudo] password for user: *******
root@endless:/sysroot/home/user# nautilus

In the new folder - START-BUTTON - to move files qBittorrent-3.3.7.desctop
In the new folder -STARTUP-FILES - to move files qBittorrent-3.3.7.glibc2.15-x86_64.AppImage
Create bookmarks for quick access to files:

Copy the files in the directory indicated in the screenshot:

(copy icon)

##Reboot systems

##Global Search:
write - qb

If done correctly, you entered the path to the files, set file permissions on execution.
Then everything will work.

Good luck.


Thank you very much. I will try it!!!

Hi roddy,

Is there any update on the issues? Also, Dropbox is missing from the App Center.


Hi, Vinodh.

Here is the status on the issues in this thread:

  • Frost Torrent: the problem was that the launcher was checking for a JRE named “java” and ignoring the “openjdk” that is installed on Endless. We are in the process of testing a change that we expect to fix this.

  • Translate: I was wrong about this being a Flatpak issue. One of our developers investigated and found that Google has started charging for use of their translation API that drives the application. We are considering our options. In the meantime, I’d recommend just going to in the browser. (In fact, one of our options may be to replace the custom app with a simple webapp that just opens in a standalone browser window, similar to how the Facebook, WhatsApp, and Gmail webapps work. See my suggestions at if you’d like to create such a webapp link yourself,)

  • VLC: we have tickets open in our internal bug tracker for the MIME type handling and for playback from external HDDs, but it is going to be at least a few weeks before we will be able to work on these.

  • Dropbox: we updated to the latest version on Friday, and our QA team tested it today, so I’m pretty sure that it is there. Please try going to the Updates tab in the app center and click on the circular arrow button in the upper-left corner to refresh the app data. Then, it should definitely show up if you search for “dropbox”. If that does not help, please let me know. (And, if it does help, that is curious that the updates are not getting refreshed automatically – they are supposed to be refreshed at least once per day, but perhaps that is not working reliably. I’ll plan to investigate further.)


1 Like

Frost Torrent should be working again now. Hit the refresh button on the Updates page of the app center, then you should be able to update to a working version of the app. Let me know if you run into any further issues with it.

1 Like

Substituir o aplicativo personalizado por um aplicativo da web simples pela versão mobile do Google Tradutor
A versão mobile é parecida com antigo aplicativo

Thanks, @LeandroStanger. Yes, the mobile version of the Google Translate web site might be an interesting option for us to consider.

1 Like

Hi, I’ll post this here, since I think it’s the right topic. Frostwire doesn’t work. It doesn’t search, I also tried to open .torrent from File - nothing. I installed it on Android - works fine. What am I missing? Thank you in advance!
eos-diagnostic-170913_185732_UTC 0300.txt (380.3 KB)

If you’re just looking for a BitTorrent application, rather than FrostWire specifically: may I suggest installing Transmission instead?

Yes, installed Transmission already. Thank you!!

1 Like

A quick update on this old topic… We no longer build and support FrostWire / Frost Torrent. As previously mentioned, Transmission is our recommended BitTorrent client.

If anyone feels so inclined, if a modern version of FrostWire were added to Flathub, it would become available on Endless once again.