HDMI monitor does not work

I have an old Sony Vaio Laptop, working ok, but I can’t manage to get an HDMI monitor working on it. The monitor works fine with every other Linux distro, I believe it has worked before in Windows, except for some distros having overscan problems (the monitor seems to be a TV, whatever diference that might mean, and this is the reason for the overscan). Please, any insight will be most helpfull.

What does happen when you attach it? Do you see any indication in the system settings (Displays) that it has been connected?

Can you please provide the following after you connected the external Display:

  1. Output of the xrand command
  2. A diagnostic of EOS (command: eos-diagnostics; Upload the generated file)

Thanks a lot for your help!

I don’t know how to upload the eos log, it seems to be too large to be accepted, there is also a complain about my not being allowed to post more than two links. This seems to be the xandr

Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
LVDS-1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1600x900 59.94*+ 59.94 59.82
1440x900 59.89
1400x900 59.96 59.88
1440x810 60.00 59.97
1368x768 59.88 59.85
1360x768 59.80 59.96
1280x800 59.99 59.97 59.81 59.91
1152x864 60.00
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
VGA-1 disconnected (normal left inverted right x axis y axis)

How big is the Diagnostic, currently the Limit for .txt Files is 50 MiB in the Forum.

BTW, when I connect the HDMI cables, the monitor goes off, for a time slightly longer than a blink, than goes back to not working.

IDK the size, I just copy and paste it. You seem to be talking about attaching the file, how should I do that?

When creating a new Answer, theres a symbol in the editor window: image
Click on it and select the diagnostic file from your Home Directory.

Awesome! Here it is! Thanks a toneos-diagnostic-200920_104049_UTC-0300.txt|attachment (712,0,KB)

There must have gone something wrong, there’s no attachment in your answer - edit it and try it again :slight_smile:

Holy mess! Here I go again.eos-diagnostic-200920_104049_UTC-0300.txt (712,0,KB)

Did you also check on Settings>Display?

Thanks, Byron, I apreciate your help. I did check the display tab, but unlike what I get in other distros, there is no setting for the external display. The built in shows fine, and I could easily change resolution or other stuff, but the external display does not exist at all in the tab. And it makes no diference if I turn the computer on with the HDMI cable plugged in or not, nor does it make any diference if I install Endless OS with the cable plugged in or not.

Sadly, you are probably out of luck with this one. Your model has dual graphics (Intel / NVIDIA) and the HDMI port is only routed to the NVIDIA card.

Normally, this would’nt be a issue with EOS, because when using a dual graphics setup, the more powerful dedicated nvidia card will be used always - but in your case, the card is too old and is no longer supported by the proprietary NVIDIA driver used in EOS :frowning:

In other linux distributions, the Nouveau driver is used, which supports your card, but has it’s own issues (poor performance for example; no support for modern cards)

I see, that’s really bad. Why does it work on other distros? Is it possible to use the drivers used on Pop OS, for instance? Does that switch (stamina/speed) make any diference? I believe it switches cards)

From the manual, the switch is for:

  • Stamina: Use integrated Graphics
  • Speed: Use dedicated Graphics

Which Distribution (Version) have you tried?

The ones that work out of the box are mint 20 (all desktops) and pop-os 20.04; debian and ubuntu do not work. I belive the switch works only on windows, because I don’t see the lights turning on as I use it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.