How to set VGA monitor to be primary while running from the live USB stick?


#1

I would like to install the OS on a system that has a buggy hardware which makes the x server to start with two monitors but only one is really existing. On other Linux distros, I was used to solve this with the following command:
xrandr -d :0 --output VGA1 --auto --primary --output LVDS1 --off

But currently I don’t know how to run that command because all I can see it’s the nice desktop background and nothing else. No languange selection, no windows, no widgets, etc, Just the nice picture of the desktop’s background. The mouse has the pointer reacting but it will disapear if I move it to the top left side. I assume this is normal in a way: the x server thinks I have two monitors and probably the primary one is on the left side.

The stick is created recently and I think the OS is at v3.5:
$ ls -l /stick/endless
-r–r--r-- 1 user 1049715 6664794112 Jan 8 18:09 endless.img
-r–r--r-- 1 user 1049715 8325924 Dec 13 14:57 eos-eos3.5-amd64-amd64.181212-202510.base.boot.zip
-r–r--r-- 1 user 1049715 833 Dec 13 14:57 eos-eos3.5-amd64-amd64.181212-202510.base.boot.zip.asc
-r–r--r-- 1 user 1049715 833 Dec 13 14:57 eos-eos3.5-amd64-amd64.181212-202510.base.img.asc
drwxr-xr-x 1 user 1049715 0 Jan 8 17:47 grub/
-r–r--r-- 1 user 1049715 45 Jan 8 18:09 live


#2

Try following what we did in this thread:

If you find this to be successful, please share diagnostic logs, then I will submit a modification to the Linux kernel so that you no longer suffer this difficulty on any version of Linux.


#3

Thanks! This looks indeed to be the same problem on my side too. The trick with the ESC key pressed after the BIOS got me into the GRUB menu, SHIFT didn’t help at all. Starting with video=LVDS-1:d forced the primary display to be what I actually see and got to the install wizard. But now, when starting from HDD, I’m not able to make the same trick. I know the timing is very difficult and I might have to try a lot of times to get it right but after many tries I decide to take a break.
Maybe there should be a GRUB timeout in a debug version of the installer so that I can edit the boot line without big effort. I will try to get also the diagnostic logs.


#4

Try to get into your BIOS’s Boot device menu, where you can select which device to boot from. Select the relevant device, press enter. Wait for the screen to go black, then immediately press Esc.

If that doesn’t help, try just hammering Esc repeatedly during boot. If you press it too many times you will end up at the grub prompt, but from there you can run normal in order to get back to the grub menu.


#5

Looks like I was very lucky in getting to that Grub menu the first time. Today I’ve tried to reach that same menu with the same technique but I had no luck when running from the USB stick nor from the HDD. Yes, I have tried to press Esc right after the BIOS’s boot menu, no luck. Hammering Esc repeatedly during boot didn’t help either. Lady Fortuna keeps looking other ways and udev init is starting instead.
Probably at this moment there is nothing else I can do and since the procedure is so frustrating, I will step aside from further attempts. Maybe when I will feel lucky I will try again. Or maybe when a debug version will be available which would make the Grub menu to wait a few seconds.


#6

That’s weird. In my opinion the timing is not that hard, and bashing escape quickly and repeatedly should be a fail-safe way of doing it.

Two other quick ideas:

In your BIOS setup turn off any options related to Fast Boot. (Maybe the keyboard is not initialized by the BIOS in time for grub?)

Secondly, I wonder if you aren’t booting the system in UEFI mode, in which case Esc is not the right way to reach the grub prompt. Perhaps you can look around in the BIOS to see if you can disable “Legacy Boot” / “CSM” mode, or if in the boot options selection screen you have a UEFI and a non-UEFI option then be sure to select the UEFI option.

And the important point to do this is when booting the installer, since if you boot the installer in non-UEFI mode then it will also make your final installation boot as non-UEFI. So ensure that you install in UEFI mode in order to have the final install also boot as UEFI, at which point pressing Esc to get into grub should work without much hassle.


#7

I don’t have the system anymore. I remember that in BIOS there were no Fast Boot options.
The way I’ve started the system from the USB stick was by pressing a hot key for the BIOS’s boot menu. In that boot menu, I saw two entries for my stick: a legacy boot option and the UEFI boot option. I’ve selected the UEFI boot option.
I will mark the previous answer that helped me to see on the right screen and I will come back if later I have access to that box again.


closed #8