How to use Japanese in Endless

localization

#1

Hello,

I bought a new computer, the OS is ENDLESS. I tried to use japanese language and choose Anthy for keyboard layout. But I couldn’t type japanese.

I don’t know what I should do. Is there any way to use japanese?

Thanks


#2

@gat0: Thanks for reporting this. I think it’s a problem with the Japanese (Anthy) input method. The keyboards that seem to display Japanese characters are Japanese (kana) and Japanese (macintosh).

I’m not an expert in Japanese by any means though, so I can’t tell if they have all of the characters that you’ll need. Can you try switching into one of these and letting me know if it works?

###Here’s how to start using the Japanese (kana) keyboard:

  1. Search for “Language” in the global search and select the Region & Language result.
  1. Add a new keyboard layout. Click on the + button to add the Japanese (Kana) keyboard (I’ve circled it in red).

You can view the keyboard layout by clicking on the keyboard icon (I’ve circled that in blue).

  1. Make sure you’re in Japanese (kana) mode. :slight_smile: You should now be able to use that keyboard and type Japanese characters. Just make sure that you have that keyboard selected by making sure that there’s a “ja” to the right of the time on the bottom bar. You can use that language toggle to go from the Japanese keyboard to the English keyboard.

###ProTip:
You can switch between keyboards (like English and Japanese) easily by pressing Super + Space on your keyboard. (The Super button is often a Windows key)


#3

@gat0 Yes, thank you for reporting this. I just confirmed that the anthy input method is broken on Endless OS 3.1. It is working on my development laptop, so I expect we will be able to fix it for the upcoming 3.2 release. For what its worth, anthy is a phonetic input method, which works by typing the English/Latin characters that sound like the Japanese word.

So, for instance, when it is working, typing “konnichiha” yields the following Japanese characters: “こんいちは”, which I think is correct, though I don’t speak Japanese.

Hopefully the kana or macintosh keyboard layout will help in the meantime, and do let us know if you have any problems with anthy after we release version 3.2.

Roddy


#4

Thank you for answering. I tried to switch into Japanese(kana) and it works.

And can you tell me when you release version 3.2?


#5

I’m glad that worked for you. We will post on the forum when the 3.2 release is available. We expect it to be in about 3 weeks.

Roddy


#6

@gat0 Version 3.2.0 is available for upgrades now. Please try upgrading and let me know if you still have any problems using the anthy input method.

Roddy


#7

I tried Version 3.2.0. But I still can’t use the anthy input method.


#8

@gat0 for a temporary fix you can try running this in a terminal:

sudo cp -aT /ostree/deploy/eos/deploy/*/var/lib/anthy /var/lib/anthy

If you’ve updated the system since installing you may need to replace the * with one of the two directory names there. We’ll try to get a proper fix into a future release of Endless OS.


#9

Hello. I got today new computer with Endless OS 3.2.5 (170816-180543), but I also can’t type in Japanese with Anthy. Japanese Kana and Japanese Macintosh are not sufficient because I only can type katakana (a part of Japanese writing system), whereas I also need to type in hiragana and kanji. Also, the typing is in kana mode, I want to have phonetic one.


#10

Upgrade to Endless OS 3.5.3

Settings :arrow_right: Details :arrow_right: Look for updates


You will upgrade to Endless OS 3.3.19 repeat the procedure to upgrade to 3.5.3


#11

Thank you for the quick response. I updated to 3.5.3 but it still doesn’t work. What else should I do?


#12

Did you try the command I suggested above:

This should allow you to use Anthy.


closed #13