HP Stream boot error failed with error -2

I’ve installed EndlessOS on an HP Stream on the local disk as the only OS. The install works correctly and boots into Endless but when I shutdown and reboot, I get the error also in the screenshot:

[19.538475] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2

I have technical skills but am very much a novice with Linux and EndlessOS. If there is a technical fix for this I should be able to perform it if you could give me some direction.

Thank you so much!

Curtis

Can you please provide us a diagnostic by opening Terminal and running:

eos-diagnostics

Then, upload the generated file into this thread.

eos-diagnostic-220922_191927_UTC-0400.txt (281.8 KB)

Thank you, I’ve uploaded the file.

Here is part of the log:

kernel: usbcore: registered new interface driver btusb
kernel: Bluetooth: hci0: RTL: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
kernel: Bluetooth: hci0: RTL: rom_version status=0 version=1
kernel: Bluetooth: hci0: RTL: loading rtl_bt/rtl8723b_fw.bin
kernel: Bluetooth: hci0: RTL: loading rtl_bt/rtl8723b_config.bin
kernel: bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
kernel: Bluetooth: hci0: RTL: cfg_sz -2, total sz 22496

The rtl_bt/rtl8723b_config.bin should come from upstream linux-firmware. However, the firmware files/configs usually come from the chip vendor which is Realtek for this case. But, Realtek has not sent it to upstream now.

Great, any suggestions on how to fix this?

I would be ok with disabling the Bluetooth if you think that would fix the issue and if someone could walk me through how to do that. Thanks!

To completely disable bluetooth, you would need to disable the driver (rtl8723be) entirely, but that won’t work as the driver is responsible for Wifi on the same card too. So when you disable it, you will loose Wifi and that’s probably not desirable.

Does the system hang during shutdown with the error shown in your first post? E.g. is it just a cosmetic issue or does it really affect system usability?

You’re correct, having wifi is important.

The system hangs on boot up. I cannot get past the error posted which makes the OS unusable. Any other ideas on how to get past this error?

Thanks!

Hm, i don’t think i fully understand. In your first post you said that booting is possible and the error shows during shutdown?

Or does it boot once after a fresh install and then stops booting with the error shown in the photo?

The latter, I can boot into EndlessOS after the initial install but not again. The screenshot I shared is from the bootup. I’m not able to get into the GUI after the initial install.

OK, i don’t think that the two issues are related. Can you please press ALT-F2 when hanging on the bootscreen. There should a login prompt appear. Can you login there and run eos-diagnostics, then reboot with reboot.

Now reboot with the live USB stick, grab the file formerly created from eos-diagnostics and upload it here.

Hi egrath,

My second post above is the attachment of what you requested. Let me know if you need me to post something else.

Thanks!

There seems to be an issue that the Xorg server which is responsible for graphical output is not able to make use of the IGP graphics from your processor. Not fully sure why, as it should be supported.

Can you please run the following command, after logging in with Ctrl-Alt-F2:

sudo sed -i s/.*WaylandEnable.*/WaylandEnable=true/g /etc/gdm3/daemon.conf
reboot

This will switch from Xorg as the display server to Wayland (which is the successor but still yet not the default choice). Does that makes any difference?

/edit: Question: Do you have a external monitor attached or are you just using the internal LCD display?

1 Like

egrath,

Thank you, this command did the trick! I appreciate you helping me get this issue resolved!

Thanks,

Curtis

I forgot to answer your /edit: question. No, there was not an external monitor being used. I was just using the laptop’s built-in screen.